Bug 802533 - Which non Red Hat OS'es will we support gluster client on?
Which non Red Hat OS'es will we support gluster client on?
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: unclassified (Show other bugs)
unspecified
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Vijay Bellur
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 14:38 EDT by Eco
Modified: 2014-10-19 19:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 01:29:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eco 2012-03-12 14:38:27 EDT
Description of problem:
In SFDC 00607550, customer ESRI has several "client" AMI's mounting Gluster that are running SuSE.  Which operating systems/distros will we support running clients on?  In their case, they can either take the risk that an RPM install on SuSE will work (they have not seen issues so far using Gluster 3.2.3 and 3.2.2 clients), or else compile from source.  In either case, for this or other distributions, what are the criteria under which we would support clients?  Will we mandate that if clients experience an issue that they must be tested on a supported Red Hat OS / Gluster version?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This question is raised for the legacy Gluster AMI but the scope extends to physical servers as well.  We should also define if there would be any difference in supportability for instances running in AWS versus physical.
Comment 1 Amar Tumballi 2012-03-16 02:08:49 EDT
This question should be addressed by multiple teams here IMO. 

we will have only RPM packages to start 3.3.0 release, built on RHEL and Fedora. Anyone using other flavours can use NFS to mount the volume.

Case by case we can start providing packages for other flavours.
Comment 2 Amar Tumballi 2012-04-17 15:15:28 EDT
Moving this bug out of my name, as its a policy decision. (rather should we consider this type of questions as a bug ? what should be resolution for these after answering?)
Comment 3 Vidya Sakar 2012-05-11 01:29:35 EDT
For the near term, the gluster install on the client side will be supported for RHEL customers. Non-RHEL customers can use NFS or CIFS which we will test in the standard way to make sure we pass the interop tests.
Comment 4 Scott Haines 2012-07-02 14:12:40 EDT
Although closed as not a bug, moving this to component: unclassified as we are removing component: porting. Before that can happen, there can be no bugs logged against the component.

Note You need to log in before you can comment on or make changes to this bug.