Bug 802607 - reset high-speed USB device (sata drive and USB connection)
reset high-speed USB device (sata drive and USB connection)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 00:39 EDT by George R. Goffe
Modified: 2012-09-30 02:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 09:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redacted /var/log/messages (17.71 KB, application/octet-stream)
2012-03-13 00:42 EDT, George R. Goffe
no flags Details
gzip'd copy of parts of /var/log/messages during a problem event. (2.85 KB, application/x-gzip)
2012-03-23 16:48 EDT, George R. Goffe
no flags Details
gzip'd copy of parts of /var/log/messages during a problem event. (3.38 KB, application/x-gzip)
2012-04-12 05:26 EDT, George R. Goffe
no flags Details
Clip from /var/log/messages (14.36 KB, application/octet-stream)
2012-05-03 14:50 EDT, George R. Goffe
no flags Details
gzip'd exerpts from /var/log/messages relating to this problem (3.11 KB, application/x-gzip)
2012-09-30 02:10 EDT, George R. Goffe
no flags Details

  None (edit)
Description George R. Goffe 2012-03-13 00:39:51 EDT
Description of problem:

Random device resets causing data loss.

Version-Release number of selected component (if applicable):

3.2.9-1.fc16.x86_64.debug

How reproducible:

This problem appears to be randomly occurring and not especially associated with heavy I/O. One failure occurred with the device NOT mounted and NO I/O activity.

Steps to Reproduce:
1.Connect the device and power it on
2.System sees the device
3.Mount the device
4.Use the drive and wait for this problem to happen.
  
Actual results:

See above.

Expected results:

Normal drive operations.

Additional info:
Comment 1 George R. Goffe 2012-03-13 00:42:27 EDT
Created attachment 569546 [details]
redacted /var/log/messages

This bug has a lot of similarities to this bug, "Bug 782280 - ext4 write took more than 2 minutes to complete"
Comment 2 Dave Jones 2012-03-22 12:45:30 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 12:49:54 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 12:59:32 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 George R. Goffe 2012-03-23 05:06:37 EDT
Dave,

I just tested and after a few minutes got the same result.

Do you need more information?

Regards,

George...
Comment 6 George R. Goffe 2012-03-23 16:48:52 EDT
Created attachment 572377 [details]
gzip'd copy of parts of /var/log/messages during a problem event.

Dave,

Here's the excerpt from /var/log/messages for the time when this latest problem appeared.

I'm wondering if my setup is the problem. I have a usb-splitter 1 in, 4 out which connects one of the 4 to a KingWin usb/sata external connector.

Regards,

George...
Comment 7 George R. Goffe 2012-03-23 16:51:25 EDT
Dave,

This time I used the cp command to create the problem instead of a "tar -cvlf - * | (cd /sdc1/wtf;tar -xvpf -)"

The key message looks like this: "   1210 [52205.619432] sd 10:0:0:0: [sdb] Unhandled error code"
Comment 8 George R. Goffe 2012-04-10 03:04:24 EDT
Dave,

I have been running on this kernel: "3.3.0-8.fc16.x86_64.debug #1 SMP Thu Mar 29 18:14:11 UTC 2012 x86_64 GNU/Linux" for the past 3 days + and have NOT seen this error. I would say that this bug is fixed now (knock on wood).

Thanks for your help!

George...

 00:01am  up 3 days 11:35,  16 users,  load average: 1.18, 1.00, 0.97
Comment 9 Josh Boyer 2012-04-10 09:58:55 EDT
Thank you for letting  us know.
Comment 10 George R. Goffe 2012-04-12 05:26:37 EDT
Created attachment 577012 [details]
gzip'd copy of parts of /var/log/messages during a problem event.

Josh,

I spoke too soon. I'm enclosing an excerpt from /var/log/messages that shows this problem but there's also a stack dump and some other messages that I'm thinking you might find interesting. If I need to file a new bug for the stack dump, let me know and, if you can, please suggest who I should send it to.

Regards,

George...
Comment 11 George R. Goffe 2012-05-03 14:50:14 EDT
Created attachment 581932 [details]
Clip from /var/log/messages

Josh,

This just happened a few minutes ago after several days of blissfull operation.

George...
Comment 12 George R. Goffe 2012-09-30 02:09:08 EDT
Josh,

This problem just re-appeared from my making a 1TB Seagate laptop drive busy. Effectively, the hardware has not changed except for the new drive. Sigh.

I'm enclosing excerpts from /var/log/messages. There's a trace dump in this file. Perhaps this will lead to a solution of this problem?

Regards,

George...
Comment 13 George R. Goffe 2012-09-30 02:10:16 EDT
Created attachment 619323 [details]
gzip'd exerpts from /var/log/messages relating to this problem

Note You need to log in before you can comment on or make changes to this bug.