Bug 802630 - Need document for hwtable_regex_match feature of multipath.conf
Need document for hwtable_regex_match feature of multipath.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Ben Marzinski
Gris Ge
:
Depends On:
Blocks: 824243 856798
  Show dependency treegraph
 
Reported: 2012-03-13 02:14 EDT by Gris Ge
Modified: 2012-09-12 15:56 EDT (History)
10 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-54.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
: 824243 (view as bug list)
Environment:
Last Closed: 2012-06-20 10:38:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-03-13 02:14:49 EDT
Description of problem:

Neither manpage nor "/usr/share/doc/device-mapper-multipath-0.4.9" provide any info about "hwtable_regex_match" feature introduced by Bug #744756.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-48.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. No document found for "hwtable_regex_match"

  
Actual results:
No document to explain how "hwtable_regex_match" work.

Expected results:
https://bugzilla.redhat.com/show_bug.cgi?id=744756#c15 could be good document for this parameter.
quote:
"hwtable_regex_match". Setting
it to "yes" will cause the user devices configs to be regex matched with the
builtin configs to determine if they should modify an existing config or create
a new one.   It defaults to "off".

Additional info:
Comment 1 Ben Marzinski 2012-04-10 21:17:12 EDT
Documentation added
Comment 4 Gris Ge 2012-04-26 23:16:21 EDT
Ben,

Where you store the documents?

I got nothing in /usr/share/docs

====
[fge@RHEL6-Stable ~]$ grep hwtable /usr/share/doc/device-mapper-multipath-0.4.9/*
[fge@RHEL6-Stable ~]$ rpm -q device-mapper-multipath
device-mapper-multipath-0.4.9-54.el6.x86_64
====

Thanks.
Comment 5 Ben Marzinski 2012-04-26 23:49:28 EDT
The multipath.conf man page.
Comment 6 Gris Ge 2012-04-27 04:58:01 EDT
These is a typo in it:
====
If set to yes , user device configs will be regular expression matched against the builtin configs to determine if they should modify an existing config or create a new one.  If set to  no  , user device configs will be string matched against the builtin configs to determine if they shoudl modify an existing 
#                                                ^^^^^^
config or create a new one. Default is no
=====

And meanwhile, can you also add description to "multipath.conf.annotated" and "multipath.conf.defaults". 

Thanks
Comment 7 Ben Marzinski 2012-04-28 01:08:10 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: To modify a built-in device configuration in dm-multipath, the user configuration had to match the vendor and product strings exactly

Consequence: This caused problems, since the vendor and product strings are regular expressions.

Change: A new default configuration option was added, "hwtable_regex_match". If this is set to "yes", instead of using string matching, the vendor and product of the user configuration is matched against the built-in configurations using the same regex matching as the devices use. The option defaults to "no"

Result: Users can now simply set hwtable_regex_match and copy the vendor and product strings from their devices when modifying the built-in device configurations, and they will automatically modify the correct configuration.
Comment 8 Ben Marzinski 2012-05-16 22:06:31 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1 @@
-Cause: To modify a built-in device configuration in dm-multipath, the user configuration had to match the vendor and product strings exactly
+No documentation needed-
-Consequence: This caused problems, since the vendor and product strings are regular expressions.
-
-Change: A new default configuration option was added, "hwtable_regex_match". If this is set to "yes", instead of using string matching, the vendor and product of the user configuration is matched against the built-in configurations using the same regex matching as the devices use. The option defaults to "no"
-
-Result: Users can now simply set hwtable_regex_match and copy the vendor and product strings from their devices when modifying the built-in device configurations, and they will automatically modify the correct configuration.
Comment 9 Gris Ge 2012-05-22 01:12:06 EDT
Ben,

Any reply for comment #6?
You want it fixed in RHEL 6.4?
Comment 10 Ben Marzinski 2012-05-22 12:18:31 EDT
I was planning on putting this in if was going to respin the package for 6.3.  But it doesn't look like I'm going to do so. So, I'll fix this for 6.4.  Unless I do end up doing a respin
Comment 11 Gris Ge 2012-05-23 00:01:32 EDT
I will verify this bug and clone it to RHEL 6.4 for future update.
Comment 13 errata-xmlrpc 2012-06-20 10:38:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0946.html

Note You need to log in before you can comment on or make changes to this bug.