Bug 802726 - [glusterfs-3.3.30qa27] - 'rm -rf .glusterfs' succeeds on nfs mount
[glusterfs-3.3.30qa27] - 'rm -rf .glusterfs' succeeds on nfs mount
Status: CLOSED DUPLICATE of bug 802478
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
pre-release
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: Amar Tumballi
BETA1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 06:56 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 08:01:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2012-03-13 06:56:03 EDT
Description of problem:
rm -rf .glusterfs succeeded on nfs mount with zero exit status. But anyway .glusterfs was not removed from the back-end. 

Version-Release number of selected component (if applicable):
glusterfs-3.3.0qa27

How reproducible:
Often

Steps to Reproduce:
1. Create and start a single node distribute volume.
2. Mount via fuse and create some data.
3. Now run stat .glusterfs, rm -rf .glusterfs, cd .glusterfs etc. All of them will fail with No data available error. (currently)
4. Now umount the volume and mount again from nfs with nolock option.
5. Run rm -rf .glusterfs from the nfs mountpoint. The command succeeds.

Actual results:
The rm -rf .glusterfs succeeds with zero exit status. But .glusterfs is not removed from the back-end.

Expected results:
Ideally behavior 'rm -rf .glusterfs' should be consistent in fuse and nfs volume. Even it can't be same, there should be some error must be thrown to the user.

Additional info:

After above operations I checked in back-end and .glusterfs had a gfid set on it.
Comment 1 Amar Tumballi 2012-03-13 08:01:54 EDT

*** This bug has been marked as a duplicate of bug 802478 ***
Comment 2 Anand Avati 2012-03-14 06:21:19 EDT
CHANGE: http://review.gluster.com/2936 (storage/posix: don't allow rmdir()/lookup() on HIDDEN_DIRECTORY) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.