Bug 802728 - [network] VPN operations unavailable in gnome-shell network indicator due to too many wireless networks
[network] VPN operations unavailable in gnome-shell network indicator due to ...
Status: CLOSED DUPLICATE of bug 799848
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-03-13 06:58 EDT by Kolos Tatar
Modified: 2012-03-21 05:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-03-21 05:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot (78.00 KB, image/png)
2012-03-13 11:26 EDT, Kolos Tatar
no flags Details
screenshot (1.04 MB, image/png)
2012-03-14 08:51 EDT, John Ruemker
no flags Details

  None (edit)
Description Kolos Tatar 2012-03-13 06:58:35 EDT
Description of problem:

It seems to me that the longer I use my system, the more wireless networks keep appearing in the menu for NetworkManager. The menu does have an overflow entry saying "More...", but on several occasions when I have been using the system for a long time and wanted to connect/disconnect to a VPN network, the operations for VPN connections were out of the screen due to too many wireless networks being listed. I can't remember if at that point the option "More..." was available or not. I'll try and attach a screenshot when it next happens.

Version-Release number of selected component (if applicable):

I'm using NetworkManager-0.9.2-1.fc16.i686 at the moment.

How reproducible:

Not 100%.

Steps to Reproduce:
1. Enable wireless
2. Connect to a wireless network
3. Connect to a VPN connection
4. Spend a good bit of time working
5. Try to disconnect from the VPN (most times I couldn't do this)
Actual results:

Can't disconnect from VPN.

Expected results:

VPN operations should still be available and the "More..." entry should hold all wireless networks that don't fit on the screen.

Additional info:
Comment 1 Kolos Tatar 2012-03-13 11:26:24 EDT
Created attachment 569701 [details]

Didn't take very long to run into it again.
Comment 2 John Ruemker 2012-03-14 08:51:55 EDT
Created attachment 569974 [details]

Same problem for me.  I often will have to disconnect from the wireless network just to get the list to refresh (making it shorter) so that I can get to my VPNs. 

Comment 3 Jirka Klimes 2012-03-21 05:54:23 EDT
gnome-shell indicator issue -> reassigning

*** This bug has been marked as a duplicate of bug 799848 ***

Note You need to log in before you can comment on or make changes to this bug.