Bug 802743 - Couldn't monitor mongo db performance from http://mms.10gen.com
Couldn't monitor mongo db performance from http://mms.10gen.com
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 07:48 EDT by bzhao
Modified: 2015-05-14 18:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 14:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bzhao 2012-03-13 07:48:55 EDT
Description of problem:
couldn't monitor mongo db performance from http://mms.10gen.com, when you login instance and check $APP_HOME/10gen-mms-agent-0.1/logs/agent.log, you can find "KeyError: 'srcVersion' "

Version-Release number of selected component (if applicable):
rhc-0.88.4-1.el6_2.noarch
rhc-node-0.88.5-1.el6_2.x86_64
rhc-cartridge-10gen-mms-agent-0.1-1.6.2-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create an app
#rhc-create-app -a php31 -t php-5.3 -p redhat -l bzhao31
2. Embed mongodb
#rhc-ctl-app -a php31 -p redhat -l bzhao31 -e add-mongodb-2.0
3. Embed rockmongo
#rhc-ctl-app -a php31 -p redhat -l bzhao31 -e add-rockmongo-1.1
4. Embed mms-agent with valid mms credentials (need to register an account from http://mms.10gen.com,get api key and secret key from setting page)
#cp settings.py $app_home/.openshift/mms/
#rhc-ctl-app -a php31 -p redhat -e add-10gen-mms-agent-0.1
5. Add your embeded mongodb to http://mms.10gen.com after log in by click "+" besides hosts
6. Add some data via rockmongo
  
Actual results:
User couldn't monitor his mongo db performance

Expected results:
It will display no data available in dashboard

Additional info:
$APP_HOME/10gen-mms-agent-0.1/logs/agent.log

012-03-13 07:38:11,852 INFO Starting agent parent process
2012-03-13 07:38:11,853 INFO Started agent parent process
2012-03-13 07:38:17,118 INFO Starting agent process
2012-03-13 07:38:17,121 ERROR Traceback (most recent call last):
  File "/var/lib/stickshift/59dff38e5d2140b8b099576d0a146733/10gen-mms-agent-0.1/mms-agent/agentProcess.py", line 66, in run
    confThread = ConfPullThread( _settings, self.mmsAgent )
  File "/var/lib/stickshift/59dff38e5d2140b8b099576d0a146733/10gen-mms-agent-0.1/mms-agent/confPull.py", line 29, in __init__
    'agentVersion' : self.mmsAgent.agentVersion
KeyError: 'srcVersion'

2012-03-13 07:38:17,122 INFO Started agent process - parent pid: 17107
Comment 1 Abhishek Gupta 2012-03-13 21:21:14 EDT
Did you configure your mongodb host at https://mms.10gen.com/ ?
Comment 2 bzhao 2012-03-14 02:44:18 EDT
yes, I have configured mongodb host at mms.10gen.com and I also checked the mms-agent, php application and mongodb's status, their status are running, I also checked secret_key, mms_key. there aren't problems.
Comment 3 bzhao 2012-03-14 04:25:23 EDT
I try it again, there is still the same issue..

$APP_HOME/10gen-mms-agent-0.1/logs/agent.log

2012-03-14 04:01:28,381 INFO Starting agent parent process
2012-03-14 04:01:28,382 INFO Started agent parent process
2012-03-14 04:01:33,631 INFO Starting agent process
2012-03-14 04:01:33,634 ERROR Traceback (most recent call last):
  File "/var/lib/stickshift/ff7fef342476452fb58cc8d6f09a6534/10gen-mms-agent-0.1/mms-agent/agentProcess.py", line 66, in run
    confThread = ConfPullThread( _settings, self.mmsAgent )
  File "/var/lib/stickshift/ff7fef342476452fb58cc8d6f09a6534/10gen-mms-agent-0.1/mms-agent/confPull.py", line 29, in __init__
    'agentVersion' : self.mmsAgent.agentVersion
KeyError: 'srcVersion'

2012-03-14 04:01:33,635 INFO Started agent process - parent pid: 10013

--------
1. login instance check $APP_HOME/10gen-mms-agent-0.1/runmms-agent.pid, its value is 10013

2. check $APP_HOME/10gen-mms-agent-0.1/mms-agent/setting.py,
mms_key = "c6da9ee8cc45ed8aac95cca8e4049afe"
secret_key = "b00ab5f39b0a75b3febc0d83eb856217"
src_version = "d14bb17d3c651418accb8f8f048018481ef3a81b"

3. check setting.py in my local
mms_key = "c6da9ee8cc45ed8aac95cca8e4049afe"
secret_key = "b00ab5f39b0a75b3febc0d83eb856217"
src_version = "d14bb17d3c651418accb8f8f048018481ef3a81b"

4. check mongodb and mms-agent status
rhc-ctl-app -a phptest -e status-mongodb-2.0
RESULT:
MongoDB is running

rhc-ctl-app -a phptest -e status-10gen-mms-agent-0.1
RESULT:
Running
Comment 4 Xiaoli Tian 2012-03-15 05:27:22 EDT
Move it to ON_QA, since we find the fix .
Comment 5 bzhao 2012-03-15 05:28:33 EDT
Passed verification on on dev 1662

Note You need to log in before you can comment on or make changes to this bug.