Bug 802767 - nfs-nlm:unlock within grace-period fails
nfs-nlm:unlock within grace-period fails
Status: CLOSED DUPLICATE of bug 802885
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 09:19 EDT by Saurabh
Modified: 2016-01-19 01:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 04:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2012-03-13 09:19:23 EDT
Description of problem:
the unlock within the grace-period fails, after the nfs server restart.

This may be because of non-reclamation of the locks earlier generated


Version-Release number of selected component (if applicable):
3.3.0qa27


How reproducible:
tried it once


Steps to Reproduce:
1. put a lock on a file
2. kill the nfs server
3. bring back the nfs server before 50 seconds
4. try to unlock the file 
  
Actual results:
the unlock fails with the error message as, 
returns:- nlm_get_uniq() returned NULL and  
unable to unlock_fd_resume


Expected results:
it should have unlocked the lock previously held after reclaiming it with in grace period 

Additional info:
Comment 1 Krishna Srinivas 2012-04-03 04:00:05 EDT

*** This bug has been marked as a duplicate of bug 802885 ***

Note You need to log in before you can comment on or make changes to this bug.