Bug 802789 - vsphere: cloud resource profile match not found
vsphere: cloud resource profile match not found
Status: CLOSED NOTABUG
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: beta6
: ---
Assigned To: Angus Thomas
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 10:12 EDT by dgao
Modified: 2012-05-01 11:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 11:11:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bad_vsphere_launch (240.26 KB, image/png)
2012-03-13 10:13 EDT, dgao
no flags Details

  None (edit)
Description dgao 2012-03-13 10:12:58 EDT
Attempting to launch a vsphere instance resulted in error from the attached screenshot.

Deployable.xml:

<!--
a deployable represents a set of instances to launch and configure at the same time
-->
<deployable name="application_stack">
<description>Deployable For JBoss Application Stack</description>
<assemblies>
<assembly name="Proxy_Server" hwp="hwp1">
<image id="11011ab6-6d0e-11e1-9117-0024e878a312"/>
</assembly>
<assembly name="Another_Proxy_Server" hwp="hwp1">
<image id="11011ab6-6d0e-11e1-9117-0024e878a312"/>
</assembly>
</assemblies>
</deployable>



[root@dell-pem600-01 log]# rpm -qa | grep "aeolus" | sort
aeolus-all-0.8.0-41.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
aeolus-conductor-doc-0.8.0-41.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
rubygem-aeolus-cli-0.3.0-13.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 1 dgao 2012-03-13 10:13:26 EDT
Created attachment 569685 [details]
bad_vsphere_launch
Comment 2 Scott Seago 2012-03-13 10:41:54 EDT
What is the definition of your hwp1? On the profiles page, does it show any matching vSphere profiles? What is the architecture of the chosen images?
Comment 3 dgao 2012-03-13 11:11:06 EDT
Yea it looks like the default hardware profile didn't match w/ vsphere. A custom hwp did the trick. Closing
Comment 4 dgao 2012-03-13 11:12:19 EDT
One additional note: the custom hardware profile I've created only had memory value but the rest of the fields were left blank. This is the only known way to match a vsphere profile.
Comment 5 Scott Seago 2012-03-13 13:43:55 EDT
Hmm. It's known that vSphere needs storage to be blank to match (since vSphere HWPs don't list storage information). A CPU value of 1 _should_ match (and, in addition, we should make sure that the default hwps match vSphere).

Note You need to log in before you can comment on or make changes to this bug.