Bug 802794 - [eap6] changing configuration for socket binding group fails
[eap6] changing configuration for socket binding group fails
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.3
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: RHQ 4.4.0
Assigned To: Libor Zoubek
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-03-13 10:16 EDT by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 06:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2012-03-13 10:16:27 EDT
Description of problem: Every time I try to add port or edit port or delete port to socket binding group using JON, configuration change fails with same result. It applies for both standalone and domain modes


Version-Release number of selected component (if applicable):
Version: 4.4.0-SNAPSHOT
Build Number: 35d045b
EAP6 ER1

How reproducible:always


Steps to Reproduce:
1.have EAP6 in inventory
2.go to 'standart-sockets' binding group
3.do some configuration changes
  
Actual results:

Configuration fails with error

Operation  returned <"JBAS014749: Operation handler failed: Service jboss.binding.http is already registered","rolled-back":true},"step-4":{"outcome":"failed","rolled-back":true},"step-5":{"outcome":"failed","rolled-back":true},"step-6":{"outcome":"failed","rolled-back":true},"step-7":{"outcome":"failed","rolled-back":true},"step-8":{"outcome":"failed","rolled-back":true},"step-9":{"outcome":"failed","rolled-back":true},"step-10":{"outcome":"failed","rolled-back":true},"step-11":{"outcome":"failed","rolled-back":true},"step-12":{"outcome":"failed","rolled-back":true},"step-13":{"outcome":"failed","rolled-back":true},"step-14":{"outcome":"failed","rolled-back":true},"step-15":{"outcome":"failed","rolled-back":true},"step-16":{"outcome":"failed","rolled-back":true},"step-17":{"outcome":"failed","rolled-back":true},"step-18":{"outcome":"failed","rolled-back":true},"step-19":{"outcome":"failed","rolled-back":true},"step-20":{"outcome":"failed","rolled-back":true},"step-21":{"outcome":"failed","rolled-back":true},"step-22":{"outcome":"failed","rolled-back":true},"step-23":{"outcome":"failed","rolled-back":true},"step-24":{"outcome":"failed","rolled-back":true},"step-25":{"outcome":"failed","rolled-back":true},"step-26":{"outcome":"failed","rolled-back":true}},"failure-description":{"JBAS014653: Composite operation failed and was rolled back. Steps that failed:":{"Operation step-3":"JBAS014749: Operation handler failed: Service jboss.binding.http is already registered"}},"rolled-back":true}>, rolled-back=false

Expected results: changing configuration must work and should fail only if it is refused by server


Additional info:
Comment 1 Libor Zoubek 2012-03-13 13:23:05 EDT
After trying this out on AS 7.1.1. final I get exactly same result as on EAP ER1
Comment 2 Libor Zoubek 2012-03-13 13:25:30 EDT
this is what appears in AS7.1.1 log. Note that "add" operation is being send even in case I was setting different port number for http.

JBAS014612: Operation ("add") failed - address: ([
    {"socket-binding-group" => "standard-sockets"},
    {"socket-binding" => "http"}
]): org.jboss.msc.service.DuplicateServiceException: Service jboss.binding.http is already registered
Comment 3 Mike Foley 2012-03-19 11:34:52 EDT
per BZ triage (crouch, loleary, mfoley)
Comment 4 Heiko W. Rupp 2012-03-29 09:21:09 EDT
This has been fixed in master 51ace66460

In addition integration tests have been written for domain and standalone servers.
Comment 5 Heiko W. Rupp 2013-08-31 06:14:12 EDT
Bulk close of old bugs in VERIFIED state.

Note You need to log in before you can comment on or make changes to this bug.