Bug 80282 - up2date can't upgrade to newer version of redhat, making remote upgrades impossible
up2date can't upgrade to newer version of redhat, making remote upgrades impo...
Status: CLOSED DUPLICATE of bug 65064
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-23 21:08 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-12-23 21:08:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Given the frequent release schedule of RedHat distributions, and given the new
policy that a given distribution will be supported for only 12 months after
release, it seems essential that up2date provide a convenient mechanism for
upgrading to newer versions of RedHat (e.g., 7.3->8.0).

This of biggest concern for those needing to remotely upgrade servers running
RedHat, when physical access to the box/console isn't possible.  It appears
there may be ways of shoehorning Kickstart to do the trick, but remote use of
Kickstart is not well documented and would be fragile.

There are many postings on Usenet of people asking how to remotely upgrade
RedHat, but there are never replies, so I imagine it is either not possible, or
not possible without considerable effort:

http://groups.google.com/groups?q=remote+upgrade+group:linux.redhat.*&hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=7cv4ul%24f54%241%40nnrp1.dejanews.com&rnum=2
http://groups.google.com/groups?q=remote+upgrade+group:linux.redhat.*&hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=003101c115f9%2427d64b80%24655a010a%40admin02&rnum=1
http://groups.google.com/groups?q=remote+upgrade+group:linux.redhat.*&start=10&hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=5812530b.0210081629.6a84559%40posting.google.com&rnum=14
http://groups.google.com/groups?q=remote+upgrade+group:linux.redhat.*&start=10&hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=aq58um%24ghv%241%40rex.ip-plus.net&rnum=12

Some kind of easy to use remote distribution upgrade mechanism (preferably via
up2date) would be of enormous utility to "small-shop" server administrators.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Actual Results:  N/A

Additional info:
Comment 1 Adrian Likins 2003-01-15 00:25:25 EST

*** This bug has been marked as a duplicate of 65064 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:50:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.