Bug 802835 - postgresql-setup needs some adjustments
postgresql-setup needs some adjustments
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
: 808256 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 11:27 EDT by Tomasz Torcz
Modified: 2012-04-11 21:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: postgresql-9.1.3-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 22:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2012-03-13 11:27:00 EDT
Description of problem:
I need to modify postgresql-setup a little before "upgrade"  worked on F17:

1) service file is searched in wrong directory. Post-usrmove, service files are in /usr/lib/systemd/system, not in /lib/systemd/system

2) grep for PGPORT is mislead by comments in postgresql.service. The result: variable "PGPORT" inside postgresql-setup (druing execution) contains:
# 5433 5432

This is taken from comment explaining how to customise, inside unit file.


Version-Release number of selected component (if applicable):
postgresql-server-9.1.3-1.fc17.x86_64
Comment 1 Tom Lane 2012-03-13 11:47:09 EDT
thanks for report, will fix.
Comment 2 Tom Lane 2012-03-13 18:23:49 EDT
(In reply to comment #0)
> 1) service file is searched in wrong directory. Post-usrmove, service files are
> in /usr/lib/systemd/system, not in /lib/systemd/system

In F17, /lib is supposed to be a symlink to /usr/lib, so while I agree this needs to be changed eventually, I don't understand what actual failure you got here.
Comment 3 Fedora Update System 2012-03-13 20:32:07 EDT
postgresql-9.1.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/postgresql-9.1.3-2.fc16
Comment 4 Fedora Update System 2012-03-13 20:32:52 EDT
postgresql-9.1.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/postgresql-9.1.3-2.fc17
Comment 5 Tomasz Torcz 2012-03-15 05:56:00 EDT
Hmm, it seem that 1) is false. I changed it during the debugging, but you are right with symlink thing, it doesn't matter.
Thanks for fix 2), it works fine now.
Comment 6 Fedora Update System 2012-03-15 22:42:34 EDT
Package postgresql-9.1.3-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing postgresql-9.1.3-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3836/postgresql-9.1.3-2.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-03-17 13:17:23 EDT
postgresql-9.1.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/postgresql-9.1.3-3.fc17
Comment 8 Fedora Update System 2012-03-17 13:18:01 EDT
postgresql-9.1.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/postgresql-9.1.3-3.fc16
Comment 9 Tom Lane 2012-03-30 10:00:22 EDT
*** Bug 808256 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-03-30 22:59:41 EDT
postgresql-9.1.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-04-11 21:53:19 EDT
postgresql-9.1.3-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.