Bug 802899 - Display port auto allocation caused tls-port is out of range
Display port auto allocation caused tls-port is out of range
Status: CLOSED DUPLICATE of bug 798220
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 13:25 EDT by Vaclav Ehrlich
Modified: 2016-10-04 00:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 17:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration of Spice display (48.94 KB, image/png)
2012-03-13 13:25 EDT, Vaclav Ehrlich
no flags Details

  None (edit)
Description Vaclav Ehrlich 2012-03-13 13:25:27 EDT
Created attachment 569737 [details]
Configuration of Spice display

Description of problem:
Creating of virtual machine (SPICE Display) with virt-manager ends with error, when auto allocated port is set out of range allowed values (is set as -1)

Version-Release number of selected component (if applicable):
virt-manager 0.9.0-10

How reproducible:
Always 

Steps to Reproduce:
1.Run virt-manager
2.Set up new VM (Win7 64bit, 1 processor, 1024 Mb RAM, 10Gb HDD)
3.In the last step (5/5) check 'Customize configuration before install' and click to Finish
4.In list which appears check if in Display Spice is type Spice (Port and TLS port is Automatically allocated)
5. Click to begin installation
  
Actual results:
Installation ends with error 'spice tls-port is out of range'

Expected results:
Installation successfully ends

Additional info:
virt-manager log:

2012-03-13 18:22:17,899 (create:1904): Starting background install process
2012-03-13 18:22:17,993 (Guest:1270): Generated install XML: 
<domain type='kvm'>
  <name>win7_64</name>
  <uuid>bccdc430-5c20-7299-cdfe-68ff6ade09e2</uuid>
  <memory>1048576</memory>
  <currentMemory>1048576</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64'>hvm</type>
    <boot dev='cdrom'/>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/><apic/><pae/>
  </features>
  <clock offset="localtime">
    <timer name="rtc" tickpolicy="catchup"/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source file='/var/lib/libvirt/images/win7_64.img'/>
      <target dev='hda' bus='ide'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu'/>
      <source file='/root/en_windows_7_enterprise_with_sp1_x64_dvd_u_677651.iso'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
    </disk>
    <interface type='network'>
      <source network='default'/>
      <mac address='52:54:00:57:23:3c'/>
    </interface>
    <input type='tablet' bus='usb'/>
    <graphics type='spice' port='-1' tlsPort='-1' autoport='yes'/>
    <console type='pty'/>
    <sound model='ich6'/>
    <video>
      <model type='qxl'/>
    </video>
  </devices>
</domain>

2012-03-13 18:22:17,994 (Guest:1271): Generated boot XML: 
<domain type='kvm'>
  <name>win7_64</name>
  <uuid>bccdc430-5c20-7299-cdfe-68ff6ade09e2</uuid>
  <memory>1048576</memory>
  <currentMemory>1048576</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/><apic/><pae/>
  </features>
  <clock offset="localtime">
    <timer name="rtc" tickpolicy="catchup"/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source file='/var/lib/libvirt/images/win7_64.img'/>
      <target dev='hda' bus='ide'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu'/>
      <source file='/root/en_windows_7_enterprise_with_sp1_x64_dvd_u_677651.iso'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
    </disk>
    <interface type='network'>
      <source network='default'/>
      <mac address='52:54:00:57:23:3c'/>
    </interface>
    <input type='tablet' bus='usb'/>
    <graphics type='spice' port='-1' tlsPort='-1' autoport='yes'/>
    <console type='pty'/>
    <sound model='ich6'/>
    <video>
      <model type='qxl'/>
    </video>
  </devices>
</domain>

2012-03-13 18:22:18,668 (error:80): dialog message: Unable to complete install: 'internal error Process exited while reading console log output: char device redirected to /dev/pts/3
spice tls-port is out of range' : Unable to complete install: 'internal error Process exited while reading console log output: char device redirected to /dev/pts/3
spice tls-port is out of range'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 44, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1910, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1223, in start_install
    noboot)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1291, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2398, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/3
spice tls-port is out of range
Comment 2 zhe peng 2012-03-14 03:31:08 EDT
This is a libvirt issue, same with Bug 798220,please update libvirt to libvirt-0.9.10-4.el6 can resolve this.For libvirt-0.9.10.5.el6,have another issue,refer Bug 801443.
Comment 3 Cole Robinson 2012-04-02 17:45:54 EDT
Okay, duping to libvirt bug as mentioned in comment #2

*** This bug has been marked as a duplicate of bug 798220 ***

Note You need to log in before you can comment on or make changes to this bug.