Bug 803050 - Recreate facet content after error
Summary: Recreate facet content after error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-13 20:55 UTC by Dmitri Pal
Modified: 2012-06-20 13:21 UTC (History)
4 users (show)

Fixed In Version: ipa-2.2.0-5.el6
Doc Type: Bug Fix
Doc Text:
Cause: User clicked on cancel in error dialog when Web UI received unexpected error such as internal server error. Consequence: Web UI got in unusable state because error message replaced page content. Fix: Error message got it's own container. Result: Error message is displayed with options how to recover from the error state.
Clone Of:
Environment:
Last Closed: 2012-06-20 13:21:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0819 normal SHIPPED_LIVE ipa bug fix and enhancement update 2012-06-19 20:34:17 UTC

Description Dmitri Pal 2012-03-13 20:55:11 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2449

In refresh (show) operation when errors other than 4001 (Not found) occur, content of a facet is replaced by error message. 

In subsequent usage of the UI the error message isn't cleared and facet content isn't recreated even when operation is successful. Such facet become unusable and user is forced to reload the UI.

UI should be able to recover from such error report.

Comment 1 Petr Vobornik 2012-03-19 18:11:54 UTC
Fixed upstream.

master:

    646a4ccde34a098ef693e75e45a2541618ed5434
    66692127c6754e9123f6bb4eaab479284112b85a 

ipa-2-2:

    801dddf6b488c68315a88305188e062fc02ff4b4
    224e8c3830d6ce40327497e91326a0c5b8a02f62

Comment 2 Jenny Severance 2012-03-19 18:21:26 UTC
to reproduce ::

Actually this problem can be reproduced with error 4001 too:

   1. Add a host via UI, e.g. test.example.com.
   2. Delete the host via CLI.
   3. Open the host in the UI, an error dialog will appear.
   4. Click Cancel, it will go back to the search page.
   5. Add the same host again via UI.
   6. Open the host in the UI, the following error message will appear in the page content (not in dialog)

Comment 4 Petr Vobornik 2012-04-26 13:11:39 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: User clicked on cancel in error dialog when Web UI received unexpected error such as internal server error.
Consequence: Web UI got in unusable state because error message replaced page content.
Fix: Error message got it's own container.
Result: Error message is displayed with options how to recover from the error state.

Comment 5 Namita Soman 2012-05-09 13:34:50 UTC
Verified using ipa-server-2.2.0-12.el6.x86_64

Followed steps above, and and got error at Step 3 in its own dialog, and no error at Step 6.

Also followed steps from bug 817878 to get internal error, got the error, but didn't see an error message replacing page content.

Comment 7 errata-xmlrpc 2012-06-20 13:21:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html


Note You need to log in before you can comment on or make changes to this bug.