This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 803080 - Install to Hard disk have a 2x 15 min timeout
Install to Hard disk have a 2x 15 min timeout
Status: CLOSED DUPLICATE of bug 797422
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: udev-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 17:53 EDT by Jesper Brouer
Modified: 2012-03-27 15:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 19:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesper Brouer 2012-03-13 17:53:21 EDT
Description of problem:

Using LiveCD Xfce to install my new laptop lenovo ThinkPad T520, but the "Install to Hard Disk" (liveinst/anaconda) have a problem.

The problem is that the installer causes two times 15 minutes timeout, before continuing.

The problem is caused by "udevadm settle --timeout=300", which stalls on some hardware.  It needs to timeout 3 times, before "anaconda --liveinst" continues, the install process.  When selecting the harddrive, anaconda chooses to invoke "udevadm settle" again, which again causes 3x 5 min timeout, this time it will show a status indicator "Examining storage devices".

Version-Release number of selected component (if applicable):


How reproducible:

Boot live CD, on a T520, mouse press "Install to Hard Disk".

Steps to Reproduce:
1. Boot live CD, on a T520
2. Start Terminal
3. Run "liveinst" (to get the stderr output)
4. Observe the timeout err ("udevadm settle - timeout of 300 seconds reached")
5. This error will come three time before it continues
6. Its possible to speedup the process by "killall udevadm" three times.
7. Continue install
8. Observer new timepout while "Examining storage devices"

Actual results:

Too long timeout, before install continues.

Expected results:

Install would start right away.

Additional info:

Output from "liveinst":
-----------------------
[root@localhost ~]# liveinst

udevadm settle - timeout of 300 seconds reached, the event queue contains:
 /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/phy0-led (2218)

udevadm settle - timeout of 300 seconds reached, the event queue contains:
 /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/phy0-led (2218)

udevadm settle - timeout of 300 seconds reached, the event queue contains:
 /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/phy0-led (2218)
 localuser:root being added to access control list
02:07:27 Starting graphical installation.
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
Comment 1 Kevin Fenzi 2012-03-13 18:08:04 EDT
Moving to udev for comment.
Comment 2 Jesper Brouer 2012-03-13 18:10:54 EDT
The timeout problem continues throughout the install process.
I have now seen this happen 10 extra times.

I speed up the process my manually killing all udevadm processes, or else the
install process, would have taken 6 hours by now...
Comment 3 Jesper Brouer 2012-03-13 18:13:51 EDT
I propose that we as a minimum/quick-fix reduce the udevadm timeout, to say 10 sec x 3 anaconda tries ?
Comment 4 Kay Sievers 2012-03-13 19:46:28 EDT

*** This bug has been marked as a duplicate of bug 797422 ***
Comment 5 Jesper Brouer 2012-03-27 15:31:49 EDT
The bug doesn't occur every time, just reinstalled my laptop without any issues (from same CD-rom, but new SSD harddisk).

Thus, I believe that Kay Sievers is on to something, in bug 797422 comment #58, where he points to a kernel commit.

Note You need to log in before you can comment on or make changes to this bug.