Bug 803120 - RFE: csprocessor.ini make default server a reference
RFE: csprocessor.ini make default server a reference
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 22:00 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.22.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-03-13 22:00:13 EDT
At the moment the default server is defined with server parameters, but does not behave as a server (ie: doesn't match urls with csprocessor.cfg).

So it should probably be instantiated as a reference to another server entry in the csprocessor.ini file. Eg:

[servers]
default = lnewson

lnewson.url=http://something
lnewson.username=me

production.url=http://skynet
production.url=me
Comment 1 Lee Newson 2012-03-24 00:02:30 EDT
Added in 0.22.4

See Bug #806133 for an example of the output.

Note: Since a user will more then likely have the same username for all the servers I've left in the default.url property. This property is used by all servers if it doesn't have its own username.
Comment 2 Lee Newson 2012-03-25 20:07:49 EDT
default.url was meant to be default.username in the previous comment sorry.
Comment 3 Lee Newson 2013-06-06 21:31:13 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.