Bug 803165 - RFE: Make the build and assemble command follow the current workflow.
RFE: Make the build and assemble command follow the current workflow.
Status: CLOSED WORKSFORME
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 00:07 EDT by Lee Newson
Modified: 2013-05-28 22:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 22:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2012-03-14 00:07:17 EDT
Currently the csprocessor build command will create a ZIP archive that can be extracted and built using publican. This could cause confusion for the users who are currently using publican. As such we should make the csprocessor build = publican build (ie rename the current assemble command to build). The build command should then be renamed to something that describes the intermediate step between the transformation between a Content Specification to a view-able document(html, pdf, etc...).

A name for the build command however hasn't been able to be finalised. Josh has suggested assemble however I feel that there isn't enough of a disambiguation between the terms so I'd like to come up with a better command that describes the process of pulling the topics from a content specification and building them into the ZIP archive that is buildable by publican.

Current Suggestions:

Assemble
Comment 1 Joshua Wulf 2012-03-14 00:14:42 EDT
The new command represents an intermediate processing step in transforming a Content Specification into built HTML output.

It takes a Content Specification on the server and transforms it into (currently) a publican book on the local filesystem, for building by publican.

The csprocessor:build command will use this intermediate step to build HTML output from a Content Spec in the following manner:


csprocessor:build

Content Spec  ---> publican book on local filesystem --[publican:build]--> HTML output

The new command accomplishes the following portion of this:

csprocessor:???

Content Spec --[csprocessor:???]--> publican book on local filesystem

Bear in mind that the intermediate step currently outputs a publican book, but in the future could be extended to output other useful formats for further processing, so the term should be sufficiently generic.
Comment 2 David Le Sage 2012-03-14 00:30:34 EDT
Unzipping is an unnecessary step from my perspective. It would be great to have the command:

Create a directory and output the .xml files into that directory and also automatically build the book (by calling on publican) to output in either PDF or HTML-Single as specified by the user.
Comment 3 Lee Newson 2012-03-14 00:37:47 EDT
Atm you can do that with the assemble command (as of version 0.22.2 anyways). The format that is used is specified by the csprocessor.ini config file. The only real reason I can see to have it only create the .zip file is if you wanted to email it or check it into svn, etc... Though maybe that isn't needed and we could remove that command (or hide it) entirely.
Comment 4 Lee Newson 2012-03-14 00:40:05 EDT
Another part that would be handy based on David's answer is a command line parameter that you could use to specify the publican build output.

ie. csprocessor assemble --format pdf

This would be good because not all books may have the same desired output.
Comment 6 Joshua Wulf 2012-05-01 04:39:59 EDT
I've set my previous comment to private because it contains potentially confusing misinformation. I've looked into more, and I was wrong.

* csprocessor assemble does everything through to putting a publican-compatible book in the assembly directory.

e.g:
csprocessor assemble
.....
Content Specification successfully assembled at /home/jwulf/public_html/Messaging_Installation_and_Configuration_Guide/assembly/publican

* csprocessor preview does everything through to publican build (plus opening the HTML preview in a browser).

* csprocessor build currently (as of cspclient-0.23.2-1) builds a zip file and puts it into the assembly directory.

e.g: 
csprocessor build
...
Output saved to: /home/jwulf/public_html/Messaging_Installation_and_Configuration_Guide/assembly/Messaging_Installation_and_Configuration_Guide-publican.zip


So for building a content spec to HTML or PDF - configurable in the csprocessor.ini file - "csprocessor preview" is the command to use.

For assembling the material needed to publish to stage, "csprocessor assemble" is the command to use.
Comment 8 Joshua Wulf 2012-07-25 07:40:51 EDT
I would expect the assemble command to act like the publish command, and leave me with a n assembled Publican book in assembly/publican.

From there my build.sh script will take it all the way to built html.

I would expect the csprocessor build command to take me all the way to built html.
Comment 9 Misty Stanley-Jones 2013-05-28 22:10:43 EDT
I think this works as expected now. Please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.