Bug 803175 - TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has no attribute 'type'
TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has...
Status: CLOSED DUPLICATE of bug 955310
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.9
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2012-03-14 01:19 EDT by Jesmon Joy Karippery
Modified: 2014-02-04 10:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-31 08:24:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug description (2.27 KB, text/plain)
2012-03-14 01:21 EDT, Jesmon Joy Karippery
no flags Details

  None (edit)
Description Jesmon Joy Karippery 2012-03-14 01:19:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesmon Joy Karippery 2012-03-14 01:21:01 EDT
Created attachment 569871 [details]
Bug description
Comment 2 Harald Hoyer 2014-01-31 08:24:07 EST
Component: system-config-network
Version: 1.3.99.21
Summary: TBf6c835f4 NCHardwareList.py:482:save:AttributeError: HwWireless instance has no attribute 'type'

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 781, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 370, in save
    self.saveHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 398, in saveHardware
    hardwarelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 482, in save
    if (hw.Type == ETHERNET or \
AttributeError: HwWireless instance has no attribute 'type'

Local variables in innermost frame:
self: HardwareList.Ethernet.eth0.Status=system
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=sky2
HardwareList.Ethernet.eth0.Description=Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller
HardwareList.Wireless.wlan0.Status=system
HardwareList.Wireless.wlan0.Name=wlan0
HardwareList.Wireless.wlan0.Type=Wireless
HardwareList.Wireless.wlan0.Card.ModuleName=ath5k
HardwareList.Wireless.wlan0.Description=Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express)
HardwareList.Ethernet.eth2.Status=system
HardwareList.Ethernet.eth2.Name=eth2
HardwareList.Ethernet.eth2.Type=Ethernet
HardwareList.Ethernet.eth2.Card.ModuleName=cdc_ether
HardwareList.Ethernet.eth2.Description=Askey Computer Corp. Scientific-Atlanta WebSTAR 2000 series Cable Modem
HardwareList.Ethernet.eth1.Status=system
HardwareList.Ethernet.eth1.Name=eth1
HardwareList.Ethernet.eth1.Type=Ethernet
HardwareList.Ethernet.eth1.Card.ModuleName=8139too
HardwareList.Ethernet.eth1.Description=Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+

modules: <netconfpkg.NCHardwareList.MyConfModules instance at 0x15016170>
hw: Hardware.Status=system
Hardware.Name=wlan0
Hardware.Type=Wireless
Hardware.Card.ModuleName=ath5k
Hardware.Description=Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express)

wvdial: <rhpl.ConfSMB.ConfSMB instance at 0x150163b0>
type: Ethernet
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x15016320>
mod: eth2

*** This bug has been marked as a duplicate of bug 955310 ***

Note You need to log in before you can comment on or make changes to this bug.