Bug 803220 - RFE: Add an option to unclassify the fonts in the list
RFE: Add an option to unclassify the fonts in the list
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-tweak-tool (Show other bugs)
17
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: James Ni
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 04:57 EDT by Akira TAGOH
Modified: 2012-08-13 03:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 03:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-03-14 04:57:32 EDT
Description of problem:
Since there seems some buggy fonts, that may be a good idea to add an option to stop classifying the fonts in sans-serif, serif, monospace and so on. this enhancements may helps for Bug#803192 say to add it for the expected alias.

Version-Release number of selected component (if applicable):
fonts-tweak-tool-0.0.3-1.fc17.noarch
Comment 1 Ani Peter 2012-03-14 05:30:26 EDT
Tested fonts-tweak-tool for Malayalam. My system had smc-meera-fonts (sans), I installed a serif font called smc-anjalioldlipi-fonts-4.4-7.fc17 and selected the same in the application. Applied, but didnt have any effect on the system, instead the same smc-meera-fonts itself is being used without any changes.

Thanks
Ani
Comment 2 Pravin Satpute 2012-03-14 06:05:26 EDT
In between i will fix issues for lohit fonts at least.

Dunno can we assume that end-user is knowledgeable regarding fonts-style and will select appropriate fonts for his locale for particular style.
Comment 3 Akira TAGOH 2012-03-14 07:03:09 EDT
Ani, I'm not sure what you did, selecting AnjaliOldLipi for serif works for me:

$ fc-match serif:lang=ml
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
$ fc-match serif:lang=ml-in
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"

FWIW you should file a separate bug for Meera like Bug#803192, because it appears in serif, but no sans-serif.
Comment 4 Akira TAGOH 2012-03-14 07:14:00 EDT
(In reply to comment #3)
> Ani, I'm not sure what you did, selecting AnjaliOldLipi for serif works for me:
> 
> $ fc-match serif:lang=ml
> AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
> $ fc-match serif:lang=ml-in
> AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"

Ah, one more result to validate the above:
$ rm ~/.fonts.conf.d/000-fontstweak-ezfc.conf
$ fc-match serif:lang=ml   
Meera.ttf: "Meera" "Regular"
$ fc-match serif:lang=ml-in
Meera.ttf: "Meera" "Regular"
Comment 5 Ani Peter 2012-03-15 00:10:40 EDT
(In reply to comment #3)
> Ani, I'm not sure what you did, selecting AnjaliOldLipi for serif works for me:
> 
> $ fc-match serif:lang=ml
> AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
> $ fc-match serif:lang=ml-in
> AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
> 
> FWIW you should file a separate bug for Meera like Bug#803192, because it
> appears in serif, but no sans-serif.

Thanks Tagoh for your reply. Lemme check again and shall revert.

I have filed a bug against meera font - See Bug#803234

Thanks
Ani
Comment 6 Ani Peter 2012-03-15 03:25:37 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Ani, I'm not sure what you did, selecting AnjaliOldLipi for serif works for me:
> > 
> > $ fc-match serif:lang=ml
> > AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
> > $ fc-match serif:lang=ml-in
> > AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
> 
> Ah, one more result to validate the above:
> $ rm ~/.fonts.conf.d/000-fontstweak-ezfc.conf
> $ fc-match serif:lang=ml   
> Meera.ttf: "Meera" "Regular"
> $ fc-match serif:lang=ml-in
> Meera.ttf: "Meera" "Regular"

Tagoh,

I agree with the above and I am also getting the above result for fc-match. But please let me know where is this change getting applied. Currently, I have selected Anjali under serif, but cant find this change getting applied anywhere. Please advise.

Thanks
Ani
Comment 7 Akira TAGOH 2012-03-15 04:13:14 EDT
You can find it out from even the above comment...
Don't you have ~/.fonts.conf.d/000-fontstweak-ezfc.conf?
Comment 8 Pravin Satpute 2012-03-15 04:24:24 EDT
Problem is not with fonts-tweak-tool. Problem is to find application which using systems default serif font.

So Ani can just open that application and see changed serif fonts. I am not able to find such application, i believe firefox uses serif but dunno it is not reflecting there.

But definitely fonts-tweak-tool doing its job perfectly :)
Comment 9 Akira TAGOH 2012-08-13 03:46:26 EDT
This feature has been added in 0.0.8-1. closing.

Note You need to log in before you can comment on or make changes to this bug.