Bug 803228 - `spacewalk-report channel-packages` on PostgreSQL is missing full_package_name for some packages
`spacewalk-report channel-packages` on PostgreSQL is missing full_package_nam...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pazdziora
Martin Minar
:
Depends On:
Blocks: 819032
  Show dependency treegraph
 
Reported: 2012-03-14 05:37 EDT by Jan Hutař
Modified: 2016-07-03 20:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-reports-1.7.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-03-14 05:37:05 EDT
Description of problem:
`spacewalk-report channel-packages` on SW 1.7 PostgreSQL is missing full_package_name column content for some packages. It have that column filled for all packages on OracleXE variant of SW 1.7.


Version-Release number of selected component (if applicable):
spacewalk-reports-1.7.1-1.el5
spacewalk-schema-1.7.55-1.el5
spacewalk-postgresql-1.7.3-1.el5
postgresql84-8.4.9-1.el5_7.1


How reproducible:
always on one system


Steps to Reproduce:
1. Create channel (IA-32, sha1, name "bzbzbz" in my case)
2. Push packages into it
   # ls *.i*6.rpm *.noarch.rpm
   4Suite-0.11.1-14.i386.rpm
   ElectricFence-2.2.2-19.i386.rpm
   mesa-libGL-7.7-2.el6.i686.rpm
   NetworkManager-glib-0.6.4-6.el5.i386.rpm
   Deployment_Guide-gu-IN-5.0.0-19.noarch.rpm
   FreeWnn-libs-1.10pl020-5.i386.rpm
   metacity-2.28.0-20.el6.i686.rpm
   XFree86-Mesa-libGL-4.3.0-35.EL.i386.rpm
   # rhnpush -u admin -p nimda --server=https://$(hostname)/APP -vv -c bzbzbz *.i*6.rpm *.noarch.rpm
3. # spacewalk-report channel-packages | sort


Actual results:
On SW 1.7 @ PostgreSQL:
# spacewalk-report channel-packages| sort
bzbzbz,bzbzbz,4Suite,0.11.1,14,,i386,
bzbzbz,bzbzbz,Deployment_Guide-gu-IN,5.0.0,19,,noarch,
bzbzbz,bzbzbz,ElectricFence,2.2.2,19,,i386,
bzbzbz,bzbzbz,FreeWnn-libs,1.10pl020,5,1,i386,1:FreeWnn-libs-1.10pl020-5.i386
bzbzbz,bzbzbz,mesa-libGL,7.7,2.el6,,i686,
bzbzbz,bzbzbz,metacity,2.28.0,20.el6,,i686,
bzbzbz,bzbzbz,NetworkManager-glib,0.6.4,6.el5,1,i386,1:NetworkManager-glib-0.6.4-6.el5.i386
bzbzbz,bzbzbz,XFree86-Mesa-libGL,4.3.0,35.EL,,i386,
channel_label,channel_name,name,version,release,epoch,arch,full_package_name

On SW 1.7 @ OracleXE or Satellite 5.4.1:
# spacewalk-report channel-packages | sort
bzbzbz,bzbzbz,4Suite,0.11.1,14,,i386,4Suite-0.11.1-14.i386
bzbzbz,bzbzbz,Deployment_Guide-gu-IN,5.0.0,19,,noarch,Deployment_Guide-gu-IN-5.0.0-19.noarch
bzbzbz,bzbzbz,ElectricFence,2.2.2,19,,i386,ElectricFence-2.2.2-19.i386
bzbzbz,bzbzbz,FreeWnn-libs,1.10pl020,5,1,i386,1:FreeWnn-libs-1.10pl020-5.i386
bzbzbz,bzbzbz,mesa-libGL,7.7,2.el6,,i686,mesa-libGL-7.7-2.el6.i686
bzbzbz,bzbzbz,metacity,2.28.0,20.el6,,i686,metacity-2.28.0-20.el6.i686
bzbzbz,bzbzbz,NetworkManager-glib,0.6.4,6.el5,1,i386,1:NetworkManager-glib-0.6.4-6.el5.i386
bzbzbz,bzbzbz,XFree86-Mesa-libGL,4.3.0,35.EL,,i386,XFree86-Mesa-libGL-4.3.0-35.EL.i386
channel_label,channel_name,name,version,release,epoch,arch,full_package_name


Expected results:
Results should be same.


Additional info:
This seems to be regression against Oracle XE DB backend or Satellite 5.4.1
Comment 2 Jan Pazdziora 2012-03-14 10:34:53 EDT
Fixed in Spacewalk master, 4b9aa7e5b1377542d102565fcebe0349aef73878.
Comment 9 Clifford Perry 2013-10-01 17:59:35 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.