Bug 803260 - sharing the IM context without enabling the option
sharing the IM context without enabling the option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 06:44 EDT by Akira TAGOH
Modified: 2012-06-18 03:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: ibus-1.4.99.20120317-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 22:31:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-03-14 06:44:01 EDT
Description of problem:
Even if turning off the "Share the same input method among all applications", all of applications shares the IM context.

Version-Release number of selected component (if applicable):
ibus-1.4.99.20120304-3.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.make sure if the option is turned off in ibus-setup.
2.run gedit and gnome-terminal say.
3.turn on IM on gedit and type something
4.switch the focus to gnome-terminal
5.type something
  
Actual results:
IM is turned on on even gnome-terminal.

Expected results:
should be turned off on gnome-terminal.

Additional info:
Comment 1 fujiwara 2012-03-14 21:22:31 EDT
Currently I'm thinking to just disappear the GUI option for F17.
The point is that if we need an option to provide the workaround for IME ON/OFF mode.
If not, we can remove the current GUI option simply.
Comment 2 Akira TAGOH 2012-03-14 21:55:56 EDT
fair enough.  It may be too late to make any changes in docbeats but this change would be something we need to document because it changes the behavior what we had kept until now.
Comment 3 Fedora Update System 2012-03-18 06:12:55 EDT
ibus-1.4.99.20120317-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20120317-1.fc17
Comment 4 Fedora Update System 2012-03-18 15:34:00 EDT
Package ibus-1.4.99.20120317-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.99.20120317-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4134/ibus-1.4.99.20120317-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-11 22:31:05 EDT
ibus-1.4.99.20120317-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Xinya Zhang 2012-06-18 03:12:10 EDT
This problem still presents in ibus.x86_64 0:1.4.99.20120428-2.fc17, and can be reproduced in the same steps of original report.

By the way, the GUI option is still missing. "yum reinstall ibus*" also doesn't help.

Is there something wrong with my configurations?
Comment 7 fujiwara 2012-06-18 03:23:39 EDT
(In reply to comment #6)
> This problem still presents in ibus.x86_64 0:1.4.99.20120428-2.fc17, and can

This problem is fixed and removed the shared option.
Your problem would be bug 831463 instead.
Comment 8 Xinya Zhang 2012-06-18 03:35:22 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > This problem still presents in ibus.x86_64 0:1.4.99.20120428-2.fc17, and can
> 
> This problem is fixed and removed the shared option.
> Your problem would be bug 831463 instead.

I see, thank you.

Note You need to log in before you can comment on or make changes to this bug.