Bug 803324 - [abrt] kernel: kernel BUG at fs/btrfs/transaction.c:1337!
[abrt] kernel: kernel BUG at fs/btrfs/transaction.c:1337!
Status: CLOSED DUPLICATE of bug 790297
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
abrt_hash:e8e0bf585fc10453e2f9a1f67ac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 08:53 EDT by efreeti
Modified: 2012-04-19 12:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 12:33:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description efreeti 2012-03-14 08:53:34 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.9-2.fc16.x86_64 root=/dev/mapper/VolGroup-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=VolGroup/lv_swap KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=VolGroup/lv_root rd.luks=0 LANG=en_US.UTF-8 quiet rhgb
comment:        I have a btrfs partition on my external usb 3.0 drive. Crash when i remove the drive from UI
event_log:      2012-03-14-20:53:10> Smolt profile successfully saved
kernel:         3.2.9-2.fc16.x86_64
reason:         kernel BUG at fs/btrfs/transaction.c:1337!
time:           Wed 14 Mar 2012 08:52:02 PM MYT

backtrace:
:kernel BUG at fs/btrfs/transaction.c:1337!
:invalid opcode: 0000 [#1] SMP 
:CPU 7 
:Modules linked in: xfs btrfs zlib_deflate libcrc32c vfat fat usb_storage ppdev parport_pc lp parport fuse fcoe libfcoe libfc scsi_transport_fc scsi_tgt 8021q garp stp llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc iTCO_wdt tg3 arc4 brcmsmac mac80211 brcmutil cfg80211 crc8 joydev uvcvideo videodev media v4l2_compat_ioctl32 acer_wmi cordic sparse_keymap rfkill iTCO_vendor_support uinput microcode i2c_i801 bcma sdhci_pci sdhci mmc_core i915 nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
:Pid: 4955, comm: umount Not tainted 3.2.9-2.fc16.x86_64 #1 Acer Aspire 5750G/JE50_HR
:RIP: 0010:[<ffffffffa06e4f3c>]  [<ffffffffa06e4f3c>] btrfs_commit_transaction+0x81c/0x820 [btrfs]
:RSP: 0018:ffff8801c566dd28  EFLAGS: 00010282
:RAX: 00000000fffffffb RBX: ffff8801c1eb60f0 RCX: 0000000000000000
:RDX: 0000000000000000 RSI: 0000000002d53000 RDI: 0000000000000000
:RBP: ffff8801c566ddb8 R08: 0000000000002000 R09: 0000000000000000
:R10: 0000000000000000 R11: 0000000000000000 R12: ffff88004efd8000
:R13: ffff8801d1ed1798 R14: ffff8801c1eb6168 R15: 0000000000000000
:FS:  00007f5b4836d800(0000) GS:ffff88025fbc0000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 00007f93158d4ae0 CR3: 000000020251e000 CR4: 00000000000406e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process umount (pid: 4955, threadinfo ffff8801c566c000, task ffff880202f80000)
:Stack:
: ffff8801c566dd58 0000000000000001 0000000000000000 ffff880202f80000
: ffffffff81090e10 ffff8801c566dd50 ffff8801c566dd50 ffffffffa06e5394
: 7fffffffffffffff 000000004e6adc00 ffff8801c566dd78 ffff88004efd8000
:Call Trace:
: [<ffffffff81090e10>] ? remove_wait_queue+0x50/0x50
: [<ffffffffa06e5394>] ? start_transaction+0x94/0x2a0 [btrfs]
: [<ffffffffa06c021c>] btrfs_sync_fs+0x6c/0xf0 [btrfs]
: [<ffffffff811a7a73>] __sync_filesystem+0x63/0x90
: [<ffffffff811a7b1b>] sync_filesystem+0x4b/0x70
: [<ffffffff8117cf6b>] generic_shutdown_super+0x3b/0xd0
: [<ffffffff8117d096>] kill_anon_super+0x16/0x30
: [<ffffffff8117d44c>] deactivate_locked_super+0x3c/0xa0
: [<ffffffff8117debe>] deactivate_super+0x4e/0x70
: [<ffffffff81198af5>] mntput_no_expire+0xb5/0x100
: [<ffffffff8119987c>] sys_umount+0x6c/0x350
: [<ffffffff81185c32>] ? path_put+0x22/0x30
: [<ffffffff815ec682>] system_call_fastpath+0x16/0x1b
:Code: e9 9b f9 ff ff 0f 0b 0f 0b 0f 0b 0f 0b 0f 0b 0f 0b be fc 04 00 00 48 c7 c7 93 80 73 a0 e8 3d 98 98 e0 e9 4d fb ff ff 0f 0b 0f 0b <0f> 0b 66 90 55 48 89 e5 53 48 83 ec 08 66 66 66 66 90 48 8b 77 
:RIP  [<ffffffffa06e4f3c>] btrfs_commit_transaction+0x81c/0x820 [btrfs]
: RSP <ffff8801c566dd28>

smolt_data:
:
:
:General
:=================================
:UUID: ef4a16b3-82cb-4888-b6ee-efba00e0eb6d
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 3990.46
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 2001
:System Memory: 7841
:System Swap: 9887
:Vendor: Acer
:System: Aspire 5750G V1.18
:Form factor: Notebook
:Kernel: 3.2.9-2.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(5348:5823:4133:1284) pci, None, BASE, N/A
:(32902:7241:4133:1284) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(32902:278:4133:1284) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4133:1284) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4133:1284) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4133:1284) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(4318:3572:4133:1285) pci, nouveau, VIDEO, GF106 [GeForce GT 555M SDDR3]
:(32902:7200:4133:1284) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:4133:1284) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(5348:17239:4187:57377) pci, bcma-pci-bridge, NETWORK, BCM43225 802.11b/g/n
:(5348:5813:4133:1284) pci, tg3, ETHERNET, NetLink BCM57785 Gigabit Ethernet PCIe
:(5348:5820:4133:1284) pci, sdhci-pci, BASE, NetXtreme BCM57765 Memory Card Reader
:(5348:5822:4133:1284) pci, None, BASE, N/A
:(32902:7171:4133:1284) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:4133:1284) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4133:1284) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4133:1284) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4133:1284) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(4147:404:4133:1284) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:257:4133:1284) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 7723398 5701007 5623704 1933312 1705888 1705888
:/dev/sda5 /boot ext4 1024 1024 508745 393638 368038 128016 127777 127777
:/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 12614875 11118076 10486064 3162112 3055104 3055104
:
Comment 1 Josef Bacik 2012-03-14 11:41:03 EDT
This happens when you just pull out the drive without unmounting it right?
Comment 2 Dave Jones 2012-03-22 13:14:41 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:16:52 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:25:36 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-04-19 12:33:40 EDT

*** This bug has been marked as a duplicate of bug 790297 ***

Note You need to log in before you can comment on or make changes to this bug.