Bug 803330 - Wrong application title display
Wrong application title display
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: 1.0.2
: ---
Assigned To: Jiri Tomasek
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 09:09 EDT by Jiri Tomasek
Modified: 2012-12-04 09:58 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Saving a resource with a blank title filled the title with "Aeolus Conductor". This bug fix removes 'set_default_title' from application_controller.rb so the title reflects the value set, including blank titles.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:58:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Displaying wrong title (194.15 KB, image/png)
2012-03-14 09:09 EDT, Jiri Tomasek
no flags Details
edit_catalog_tiltle (73.10 KB, image/png)
2012-09-20 08:50 EDT, pushpesh sharma
no flags Details
title (81.76 KB, image/png)
2012-09-20 08:51 EDT, pushpesh sharma
no flags Details

  None (edit)
Description Jiri Tomasek 2012-03-14 09:09:45 EDT
Created attachment 569984 [details]
Displaying wrong title

Description of problem:
Default application title is generated in before filter in application_controller.rb and is supposed to be overriden in the controller action. This causes wrongly displayed titles through the application where @title is used for eg. Displaying Catalog name. If I edit the catalog so it doesn't have a name, I get validation error, but the @title is set to nil and so the application default @title is not overriden and "Aeolus Conductor" is displayed instead of Catalog name which is wrong.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Edit catalog
2.clear its name input
3.press save
4.you get Aeolus Conductor in catalog title
  
Actual results:


Expected results:

I want to see blank title instead of Aeolus Conductor, when the item (eg. catalog) has no name. 


Additional info:
Comment 1 Jiri Tomasek 2012-03-14 10:01:17 EDT
fix posted in https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009565.html
Comment 2 Jiri Tomasek 2012-03-14 10:19:53 EDT
fixed in commit 30b4ac23147bfb2bda6e6ad25293dc7815f709dd
Comment 4 pushpesh sharma 2012-09-20 08:49:51 EDT
1.Edit catalog
2.clear its name input
3.press save
4.got blank in  title
  
Verified on :-
[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
Comment 5 pushpesh sharma 2012-09-20 08:50:33 EDT
Created attachment 614877 [details]
edit_catalog_tiltle
Comment 6 pushpesh sharma 2012-09-20 08:51:05 EDT
Created attachment 614878 [details]
title
Comment 8 errata-xmlrpc 2012-12-04 09:58:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.