Bug 803354 - keystone returns 500 errors after a while
keystone returns 500 errors after a while
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-keystone (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 10:14 EDT by Pádraig Brady
Modified: 2016-01-04 09:47 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-keystone-2012.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 22:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2012-03-14 10:14:06 EDT
Most times when I resume my laptop for the day I need to restart
the openstack-keystone.service or otherwise glance etc. will get 500 errors.
This traceback is logged:

OperationalError: (OperationalError) (2006, 'MySQL server has gone away') 'SELECT user.id AS user_id, user.name AS user_name, user.extra AS user_extra \nFROM user \nWHERE user.name = %s \n LIMIT %s' ('admin', 1)
. (HTTP 500)

Note only restarting keystone is required, not mysql
Comment 1 Russell Bryant 2012-03-14 10:31:04 EDT
This looks related:

    https://bugs.launchpad.net/keystone/+bug/943031
Comment 2 Pádraig Brady 2012-03-14 10:44:45 EDT
Thanks Russell, that looks like the same issue.
We can just wait for the next update I think rather than patching explicitly
Comment 3 Alan Pevec 2012-03-21 18:19:59 EDT
Confirmed, it's fixed in rc1 snapshot:

1. stop mysqld, start keystone, try keystoneclient => 500
   start mysqld w/o touching keystone, try keystoneclient => OK

2. start mysqld, start keystone, try keystoneclient => OK
   stop mysqld, try keystoneclient => 500
   start mysqld w/o touching keystone, try keystoneclient => OK
Comment 4 Fedora Update System 2012-03-24 17:55:31 EDT
openstack-keystone-2012.1-0.12.rc1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-keystone-2012.1-0.12.rc1.fc17
Comment 5 Fedora Update System 2012-03-25 17:29:10 EDT
Package openstack-keystone-2012.1-0.12.rc1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-keystone-2012.1-0.12.rc1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4690/openstack-keystone-2012.1-0.12.rc1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-11 22:27:22 EDT
openstack-keystone-2012.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.