This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 80340 - Unable to create cd from nautilus CD Creator as user
Unable to create cd from nautilus CD Creator as user
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-24 14:01 EST by Mark Cooke
Modified: 2014-03-16 22:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-30 01:03:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2002-12-24 14:01:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Due to the user not having the correct permissions to connect and operate the cd
device, in my case this is a scsi cdburner attatched to lun 0,2,0.
This is the usuall practice for these devices (as you know)

The operation works fine as root, but not as a user unless the user has access
to the device (ie correct permissions).







Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go | CD Creator
2. drag and drop files
3. Create cd
4. Error regarding incorrect permission to access device
    

Actual Results:  Above

Expected Results:  1. The user to either be put into a specialo group or have
acess to this device.

2. Disable this option for users (ie remove from panel), this will upset people,
as this is a very cool and usefull addon

Additional info:
Comment 1 Mark Cooke 2002-12-25 02:39:02 EST
Error dialog output:

cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: Permission denied. Cannot open '/dev/sg0'. Cannot open SCSI driver.
scsibus: 0 target: 2 lun: 0
scsidev: '0,2,0'
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot do mlockall(2).
Comment 2 Alexander Larsson 2003-01-06 10:37:25 EST
Do you have any /dev/cdwriter* files?

notting: Did you add the cd writer stuff to kudzu?
Comment 3 Alexander Larsson 2003-01-06 12:15:58 EST
Kudzu needs to create the /dev/cdwriter links.
Comment 4 Bill Nottingham 2003-01-06 15:53:37 EST
Ugh. This could get tricky on mixed SCSI/ide systems.
Comment 5 Mark Cooke 2003-01-06 16:01:33 EST
I presume these are just symlinks to the real devices?

Won't the 'user' still have to be in the correct group to access the cdrom burner?

If I'm told what to do I don't mind testing this out
(assuming the setup will be similar to the way cdrecord can be setup to allow a
normal user access?)
Mark
Comment 6 Bill Nottingham 2003-01-06 16:06:58 EST
The user will get access via pam_console.
Comment 7 Alexander Larsson 2003-01-08 04:47:35 EST
notting: You might want to look at the cdrom.[ch] files in nautilus-cd-burner
for some code that handles ide and scsi burners.
Comment 8 Mark Cooke 2003-01-26 15:41:09 EST
This has still not been fixed in Phoebe Beta 2, It is working as root, but still
not as a normal user.

I don't want to sound as though I'm moaning, but will this be fixed for the
final release?, as if not I would remove the option, as this will cause complaints.

Once I logged in as root, it worked perfectly every time.
Comment 9 Bill Nottingham 2003-01-30 01:03:48 EST
Fixed in 0.99.91-1, as part of updfstab.
Comment 10 Mark Cooke 2003-01-30 03:20:17 EST
will this be available on up2date? or via rawhide?
Comment 11 Bill Nottingham 2003-01-30 12:19:17 EST
Should be in rawhide soon, if not there already.

Note You need to log in before you can comment on or make changes to this bug.