Bug 803434 - [swell-foop] Help -> Content function is broken
[swell-foop] Help -> Content function is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-03-14 13:28 EDT by Petr Schindler
Modified: 2012-04-22 00:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: cogl-1.10.2-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-22 00:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-03-14 13:28:16 EDT
Description of problem:
When I try to get help (by choosing Help->Content or by pressing F1 key) nothing happens.

This is what I can see, when I run swell-foop in console:
# swell-foop

** WARNING **: Exception in closure (0x3537980) for signal handler (GtkBuilder) (handler [anonymous]). Line 54 in /usr/share/gnome-games/swell-foop/main.js: TypeError 'undefined' is not a function (evaluating 'GnomeGamesSupport.help_display(window, "swell-foop", null)')

Version-Release number of selected component (if applicable):
swell-foop - version 1.0
gnome-games-3.3.91.1-2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. run swell-foop
2. press F1
  
Actual results:
Nothing happens

Expected results:
Help should be displayed 

Additional info:
Because gnome-games is installed by default (when installing from DVD), I propose this bug as final blocker per criterion:
 "Menu sanity - the following criteria refer to both a live image and default installed system, and to all release-blocking desktops: "
 - All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items
Comment 1 Matthias Clasen 2012-03-24 18:51:55 EDT
I guess that release criterion should be amended to say ', if the application has a menubar'

I don't think this is a bug, really.
Comment 2 Petr Schindler 2012-03-26 04:26:32 EDT
The menu bar only moved to the gnome-shell panel. The F1 key doesn't work (this is feature I guess?). When you click on icon of the application, you'll get application menu. Help option is still there and it doesn't show any content. Help application says: "The URI ‘help:swell-foop/index’ does not point to a valid page."
Comment 3 Edward Sheldrake 2012-03-30 05:19:46 EDT
This applies to most of the games: glchess, gnect, gnibbles, gnobots2, gnomine, gnotski, gtali, lightsoff, quadrapassel, swell-foop.

Here is a workaround that can be added to the end of the %install section in gnome-games.spec

pushd $RPM_BUILD_ROOT%{_datadir}/help
for lang in * ; do
  pushd ${lang}
  for game in * ; do
    pushd ${game}
    test -e index.page || ln -s ${game}.xml index.docbook
    popd
  done
  popd
done
popd
Comment 4 Matthias Clasen 2012-04-09 14:09:40 EDT
Looks like it has been fixed upstream in 

http://git.gnome.org/browse/gnome-games/commit/?id=06411302e2b10ef7b183dcf8e305188038a6fa66
Comment 5 Petr Schindler 2012-04-19 09:49:11 EDT
It works properly in gnome-games-3.4.1-1.fc17.x86_64

If it will get to the stable, we can close this.
Comment 6 Adam Williamson 2012-04-20 15:41:19 EDT
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . Accepted as a blocker per criterion "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use.".
Comment 7 Fedora Update System 2012-04-20 18:30:16 EDT
cogl-1.10.2-1.fc17, epiphany-3.4.1-1.fc17, gobject-introspection-1.32.1-1.fc17, aisleriot-3.2.3.2-2.fc17, at-spi2-core-2.4.1-1.fc17, baobab-3.4.1-1.fc17, brasero-3.4.1-1.fc17, cheese-3.4.1-1.fc17, control-center-3.4.1-1.fc17, devhelp-3.4.1-1.fc17, empathy-3.4.1-1.fc17, eog-3.4.1-1.fc17, file-roller-3.4.1-1.fc17, folks-0.6.9-1.fc17, gcalctool-6.4.1.1-1.fc17, gcr-3.4.1-1.fc17, gedit-3.4.1-1.fc17, glib-networking-2.32.1-1.fc17, gnome-applets-3.4.1-1.fc17, gnome-backgrounds-3.4.1-1.fc17, gnome-boxes-3.4.1-1.fc17, gnome-desktop3-3.4.1-2.fc17, gnome-devel-docs-3.4.1-1.fc17, gnome-documents-0.4.1-1.fc17, gnome-games-3.4.1-1.fc17, gnome-keyring-3.4.1-1.fc17, gnome-online-accounts-3.4.1-1.fc17, gnome-panel-3.4.1-1.fc17, gnome-screenshot-3.4.1-1.fc17, gnome-session-3.4.1-1.fc17, gnome-shell-3.4.1-2.fc17, gnome-system-monitor-3.4.1-1.fc17, gnome-terminal-3.4.1.1-1.fc17, gnome-user-docs-3.4.1-1.fc17, gtksourceview3-3.4.1-1.fc17, gucharmap-3.4.1.1-1.fc17, gvfs-1.12.1-2.fc17, libgdata-0.12.0-1.fc17, libgnome-keyring-3.4.1-2.fc17, librsvg2-2.36.1-1.fc17, libsoup-2.38.1-1.fc17, mutter-3.4.1-2.fc17, orca-3.4.1-2.fc17, sushi-0.4.1-1.fc17, vinagre-3.4.1-1.fc17, vino-3.4.1-1.fc17, vte3-0.32.1-1.fc17, yelp-3.4.1-1.fc17, yelp-tools-3.4.1-1.fc17, yelp-xsl-3.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-6123/epiphany-3.4.1-1.fc17,gobject-introspection-1.32.1-1.fc17,cogl-1.10.2-1.fc17,aisleriot-3.2.3.2-2.fc17,at-spi2-core-2.4.1-1.fc17,baobab-3.4.1-1.fc17,brasero-3.4.1-1.fc17,cheese-3.4.1-1.fc17,control-center-3.4.1-1.fc17,devhelp-3.4.1-1.fc17,empathy-3.4.1-1.fc17,eog-3.4.1-1.fc17,file-roller-3.4.1-1.fc17,folks-0.6.9-1.fc17,gcalctool-6.4.1.1-1.fc17,gcr-3.4.1-1.fc17,gedit-3.4.1-1.fc17,glib-networking-2.32.1-1.fc17,gnome-applets-3.4.1-1.fc17,gnome-backgrounds-3.4.1-1.fc17,gnome-boxes-3.4.1-1.fc17,gnome-desktop3-3.4.1-2.fc17,gnome-devel-docs-3.4.1-1.fc17,gnome-documents-0.4.1-1.fc17,gnome-games-3.4.1-1.fc17,gnome-keyring-3.4.1-1.fc17,gnome-online-accounts-3.4.1-1.fc17,gnome-panel-3.4.1-1.fc17,gnome-screenshot-3.4.1-1.fc17,gnome-session-3.4.1-1.fc17,gnome-shell-3.4.1-2.fc17,gnome-system-monitor-3.4.1-1.fc17,gnome-terminal-3.4.1.1-1.fc17,gnome-user-docs-3.4.1-1.fc17,gtksourceview3-3.4.1-1.fc17,gucharmap-3.4.1.1-1.fc17,gvfs-1.12.1-2.fc17,libgdata-0.12.0-1.fc17,libgnome-keyring-3.4.1-2.fc17,librsvg2-2.36.1-1.fc17,libsoup-2.38.1-1.fc17,mutter-3.4.1-2.fc17,orca-3.4.1-2.fc17,sushi-0.4.1-1.fc17,vinagre-3.4.1-1.fc17,vino-3.4.1-1.fc17,vte3-0.32.1-1.fc17,yelp-3.4.1-1.fc17,yelp-tools-3.4.1-1.fc17,yelp-xsl-3.4.1-1.fc17
Comment 8 Fedora Update System 2012-04-22 00:17:29 EDT
cogl-1.10.2-1.fc17, epiphany-3.4.1-1.fc17, gobject-introspection-1.32.1-1.fc17, aisleriot-3.2.3.2-2.fc17, at-spi2-core-2.4.1-1.fc17, baobab-3.4.1-1.fc17, brasero-3.4.1-1.fc17, cheese-3.4.1-1.fc17, control-center-3.4.1-1.fc17, devhelp-3.4.1-1.fc17, empathy-3.4.1-1.fc17, eog-3.4.1-1.fc17, file-roller-3.4.1-1.fc17, folks-0.6.9-1.fc17, gcalctool-6.4.1.1-1.fc17, gcr-3.4.1-1.fc17, gedit-3.4.1-1.fc17, glib-networking-2.32.1-1.fc17, gnome-applets-3.4.1-1.fc17, gnome-backgrounds-3.4.1-1.fc17, gnome-boxes-3.4.1-1.fc17, gnome-desktop3-3.4.1-2.fc17, gnome-devel-docs-3.4.1-1.fc17, gnome-documents-0.4.1-1.fc17, gnome-games-3.4.1-1.fc17, gnome-keyring-3.4.1-1.fc17, gnome-online-accounts-3.4.1-1.fc17, gnome-panel-3.4.1-1.fc17, gnome-screenshot-3.4.1-1.fc17, gnome-session-3.4.1-1.fc17, gnome-shell-3.4.1-2.fc17, gnome-system-monitor-3.4.1-1.fc17, gnome-terminal-3.4.1.1-1.fc17, gnome-user-docs-3.4.1-1.fc17, gtksourceview3-3.4.1-1.fc17, gucharmap-3.4.1.1-1.fc17, gvfs-1.12.1-2.fc17, libgdata-0.12.0-1.fc17, libgnome-keyring-3.4.1-2.fc17, librsvg2-2.36.1-1.fc17, libsoup-2.38.1-1.fc17, mutter-3.4.1-2.fc17, orca-3.4.1-2.fc17, sushi-0.4.1-1.fc17, vinagre-3.4.1-1.fc17, vino-3.4.1-1.fc17, vte3-0.32.1-1.fc17, yelp-3.4.1-1.fc17, yelp-tools-3.4.1-1.fc17, yelp-xsl-3.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.