Bug 803438 - [iagno] Game is unplayable
[iagno] Game is unplayable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
17
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-03-14 13:46 EDT by Petr Schindler
Modified: 2012-04-18 11:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 09:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-03-14 13:46:22 EDT
Description of problem:
Computer opponent makes invalid move in third round and the game is stuck.

This is what I get in terminal:
$ iagno
Gtk-DEBUG: Connecting to session manager

** WARNING **: iagno.vala:168: Failed to load theme classic.png: /usr/share/iagno/themes/classic.png

** WARNING **: iagno.vala:100: Unable to load theme classic.png, falling back to default

** WARNING **: computer-player.vala:73: Computer chose an invalid move: 0,0

Version-Release number of selected component (if applicable):
iagno - version 3.3.91.1
gnome-games-3.3.91.1-2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. run iagno
2. try to play at least three rounds
  
Actual results:
Computer opponent doesn't move anymore

Expected results:
Computer shouldn't make a invalid move

Additional info:
Because gnome-games is in the default installation, I propose this bug as final blocker per criterion:
 "Menu sanity - the following criteria refer to both a live image and default
installed system, and to all release-blocking desktops: "
 - All applications listed under the Applications menu or category must
withstand a basic functionality test and not crash after a few minutes of
normal use. They must also have working Help and Help -> About menu items
Comment 2 Dan Mashal 2012-04-18 05:00:56 EDT
Why is this an F17 final blocker? I'm confused.
Comment 3 Dan Mashal 2012-04-18 05:06:18 EDT
Also we should consider breaking up this package by game so the whole package doesn't get screwed because of 1 game. 

In addition, I believe this belongs under NTH aka "nice to have", not blocker.
Comment 4 Petr Schindler 2012-04-18 09:11:08 EDT
Yes this should be blocker, look at the comment 1.

Luckily it works in gnome-games-3.4.0-2.fc17.x86_64 (iagno v. 3.4.0) well so I'm closing it now.
Comment 5 Dan Mashal 2012-04-18 11:05:21 EDT
Fair enough, it was 2AM and I should have read the end of it.

Glad it's resolved. :)

Note You need to log in before you can comment on or make changes to this bug.