Bug 80347 - 3Com 3c590/3c595/3c90x/3cx980 driver problems
3Com 3c590/3c595/3c90x/3cx980 driver problems
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-24 15:23 EST by Arnoud de Geus
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2.15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 10:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnoud de Geus 2002-12-24 15:23:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021207

Description of problem:
I tried to install the redhat phoebe beta.

Using the installation images to boot from floppy
I wanted to use FTP install method.

To be able to use the driver

3Com 3c590/3c595/3c90x/3cx980

for my eth1 device, I was forced to use the additional
driver disk. In previous versions this network card was
detected automatically.

Manually selecting the card, an FTP installation was
possible.

After installation, the network card gave an initialisation
problem (the boot sequence suggested to check the UTP cable).
Also manual configuration and activation of the card did not
work.

Due to the fact that I also use the machine as router and
firewall I had to roll back to the official 8.0 redhat version,
and I cannot further test teh pheobe beta.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use pheobe FTP installation
2.Additional driver disk is required for 3Com 3c590/3c595/3c90x/3cx980
3.Manullay selecting the driver works. Automatic detection fails
4.After installation the boot sequence cannot initialse and start
eth1 device.
    

Actual Results:  No activation of network card

Expected Results:  Activation of network card

Additional info:
Comment 1 Warren Togami 2002-12-24 15:57:48 EST
> for my eth1 device, I was forced to use the additional
> driver disk. In previous versions this network card was
> detected automatically.

I think this part is intentional if you read the release notes. IIRC the
bootdisk.img no longer has any drivers on it, you need the secondary disk with
network drivers.

> After installation, the network card gave an initialisation
> problem (the boot sequence suggested to check the UTP cable).
> Also manual configuration and activation of the card did not
> work.

Does it work if you manually load the appropriate kernel module before or after
enabling the network devices?
Comment 2 Arnoud de Geus 2002-12-24 19:06:58 EST
Okay, I understand that all network drivers are shifted to the
additional drivers image. Still in previous releases the detection
of the network card was automatically.

Furthermore: The problem does not seem to be related to a kernel
module that needs to be loaded. If have the exact same network card
on my eth0 device (internal network) and that card does work correctly
on boot.
Comment 3 Bill Nottingham 2002-12-30 01:06:02 EST
What are the exact errors you get?
Comment 4 Arnoud de Geus 2003-01-03 19:46:22 EST
During boot sequence as above.

Using the Network Icon from the "Start Here" dialog, and
trying to initialse the network card post installation from
"Network Configuration":
- The networkcard is shown in the "Hardware" tab
- Trying to (add and) configure in the "Devices" tab and
  Activating the card results in an error dialog being
  popped up after some time wait out. When the error dialog
  is closed using the "X" right above the "Network Configuration"
  program crashes.
Comment 5 Michael Fulbright 2003-01-13 15:06:41 EST
Not an anaconda issue.
Comment 6 Harald Hoyer 2003-01-30 07:52:56 EST
-> the boot sequence suggested to check the UTP cable

hmm, crash dump of redhat-config-netwotk would be interesting also..
Comment 7 Harald Hoyer 2003-08-05 04:32:53 EDT
more info or close this bug, please...

Note You need to log in before you can comment on or make changes to this bug.