Bug 80348 - GNUCash crashes on start
GNUCash crashes on start
Status: CLOSED DUPLICATE of bug 79068
Product: Red Hat Linux
Classification: Retired
Component: gnucash (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-24 16:35 EST by Jason McCormick
Modified: 2014-03-16 22:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason McCormick 2002-12-24 16:35:23 EST
Description of problem:
  Gnucash failed to start and terminates with an error.

Version-Release number of selected component (if applicable):
  gnucash 1.7.6 (default Phoebe)

How reproducible:
  Every time

Steps to Reproduce:
  1.  Start GNUCASH from a terminal window
    
Actual results:
  [jason@sith jason]$ gnucash
  ERROR: In procedure dynamic-link:
  ERROR: file: "libgw-gnc", message: "file not found"
  [jason@sith jason]$

Expected results:
  GNUCash to start

Additional info:
  I also tried loading the last -RH8 package provided from the GNUCash
development team with the same results.  Cannot try the raw source because it
requires guile <= 1.5.0.  I did an in-place upgrade from 8.0 to Phoebe but
GNUCash worked prior to the upgrade.
Comment 1 Jason McCormick 2002-12-24 16:38:20 EST
  I tried downgrading to the 1.7.5 that is in Rawhide and everything works fine.
 Seems to be a problem with the 1.7.6 package.
Comment 2 Bill Nottingham 2002-12-24 16:47:49 EST
There is no gnucash-1.7.6 package in Phoebe, only the 1.7.5 package in rawhide.
Comment 3 Jason McCormick 2002-12-24 20:50:43 EST
Hrmm.. musta been my mistake with looking at the GNUCash website (about the
1.7.6 version).  However whatever Phoebe loaded on my system during the upgrade
crashed with the error above.  I went and got the rawhide package and installed
it and everything worked fine.  Then I removed it and put the one from the CD
back on and it worked fine again.  So I'm not sure what triggered this error but
it did happen immediately after the upgrade because I use GNUCash every day and
nothing changed between this morning and loading up the beta.

Guess you can mark this as NOTABUG.
Comment 4 Ian Prowell 2003-01-03 03:29:52 EST
I did a clean install of Phoebe and ended up with the same problem when I
install gnucash from the packages provided with Phoebe.  I began to install the
dependencies for to rebuild gnucash from source and gnucash started working.  In
particular g-wrap-devel is needed for gnucash to function on my system.  If I
uninstall it gnucash stops working.
Comment 5 Jason McCormick 2003-01-03 07:27:37 EST
This is probably what fixed mine as well because I installed dependencies to compile by hand.  
Perhaps this needs to be made a dependency of the GNUCash package? 
Comment 6 Bill Nottingham 2003-01-03 12:35:54 EST

*** This bug has been marked as a duplicate of 79068 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:50:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.