Bug 803485 - RFE: Add crontab files for cron cartridge
RFE: Add crontab files for cron cartridge
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 15:59 EDT by Alexander Todorov
Modified: 2015-05-14 18:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 13:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2012-03-14 15:59:50 EDT
Description of problem:

At present Express has the 
daily,hourly,minutely,monthly and weekly directories under cron/

README says that scripts in these directories are executed by run-parts. It is not possible to execute a job at say 4:30 every Monday. or every 45 minutes, etc.

Allowing crontab files in the cron cartridge will make it much more flexible.
Comment 1 Mrunal Patel 2012-03-19 15:49:00 EDT
Changing severity to low since this is an enhancement.
Comment 2 Mike McGrath 2012-05-15 13:11:43 EDT
As much as I'd like this feature, I'm Closing as WONTFIX.  We're evaluating some different infrastructure for more customized scheduled jobs.  Unfortunately there are a number of issues with cron running as multiple users (it was designed to run as root).  As such we're having to look elsewhere for a proper scheduler.

Note You need to log in before you can comment on or make changes to this bug.