Bug 803493 - On sending mail, thunderbird loads CPU to around 50% for about 20 seconds - this seems a lot.
On sending mail, thunderbird loads CPU to around 50% for about 20 seconds - t...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 16:11 EDT by Gerard Ryan
Modified: 2012-08-10 03:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 03:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2012-03-14 16:11:16 EDT
Description of problem:
Sending an email with thunderbird takes a lot of processing time. I'm not really sure if this is even a bug, it just seems far too high for transferring a couple of lines of plaintext. I'm not sure if it has always been like this, but I've noticed it a lot in the last few months. A lot of the time seems to be taken up with a progress bar, and a message saying that it's saving the message to the Sent Mail folder (On a side note, a lot of the time this saving part fails first time around when sending a message from my google apps account, not sure about from other accounts).

Version-Release number of selected component (if applicable):
10.0.1

How reproducible: 
100%


Steps to Reproduce:
1. Write email in Thunderbird
2. Send email
3. look at CPU usage in a system monitor
  
Actual results: 
Thunderbird seems to be using a huge amount of processing time.


Expected results: 
Presumably sending an email wouldn't take this amount of processor time for so long.


Additional info:
If there's any more info I can provide, I'd be happy to!
Comment 1 Gerard Ryan 2012-03-20 20:21:04 EDT
After further observation, I think it might not be thunderbird directly that's hogging the CPU time:

When an email is sent 'inline' at the end of another message, it doesn't happen. When an email is sent in a new window (e.g. a new message, or a reply popped out from having been 'inline'), then it happens. The main difference I can see between the two, are the two scrolling progress bars: one at the bottom of the message window, and a larger one in the middle of the sending status window.

Could it be these that are causing the load? Is this even considered a bug/problem?
Comment 2 Jan Horak 2012-03-27 09:41:51 EDT
Please check addon manager if you have any addon installed.
Comment 3 Jan Horak 2012-03-27 09:45:11 EDT
You may also try to run thunderbird in safe mode by: thunderbird -safe-mode or see: https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Figuring_out_what_is_responsible_for_crash for further explanation.
Comment 4 Jan Horak 2012-08-09 09:52:55 EDT
Do you still encounter this problem? If Thunderbird consumes 100% of CPU and UI freeze for couple of seconds it sounds like a bug.
Comment 5 Gerard Ryan 2012-08-09 10:28:42 EDT
I haven't used Thunderbird in a while: I've spent the last couple of months hopping between different mail clients. I'll give it a try now and report back!
Comment 6 Gerard Ryan 2012-08-09 17:42:34 EDT
(In reply to comment #4)
> Do you still encounter this problem? If Thunderbird consumes 100% of CPU and
> UI freeze for couple of seconds it sounds like a bug.

I just tried on Thunderbird 14, and I didn't experience this. I guess whatever was causing it has been fixed. Thanks! :)
Comment 7 Jan Horak 2012-08-10 03:43:19 EDT
Okay, thanks for letting me know.

Note You need to log in before you can comment on or make changes to this bug.