Bug 803502 - install_execd fails without gridengine-qmaster
install_execd fails without gridengine-qmaster
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gridengine (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 16:25 EDT by Juno Krahn
Modified: 2012-03-26 14:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: gridengine-6.2u5-10.fc15.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-25 23:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juno Krahn 2012-03-14 16:25:14 EDT
Description of problem:
Setting up execution nodes (gridengine-execd) fails because 'install_execd' aborts due to missing executables that are packaged with gridengine-qmaster

Version-Release number of selected component (if applicable):
6.2u5-8.fc15

How reproducible:
always

Steps to Reproduce:
1. cd /usr/share/gridengine
2. ./install_execd
3.
  
Actual results:
missing program >sge_qmaster< in directory >./bin/lx26-amd64<
missing program >qacct< in directory >./bin/lx26-amd64<

Missing Grid Engine binaries!

A complete installation needs the following binaries in >./bin/lx26-amd64<:

qacct           qlogin          qrsh            sge_shepherd
qalter          qmake           qselect         sge_coshepherd
qconf           qmod            qsh             sge_execd
qdel            qmon            qstat           sge_qmaster
qhold           qresub          qsub            qhost
qrls            qtcsh           sge_shadowd     qping
qquota

and the binaries in >./utilbin/lx26-amd64< should be:

adminrun       gethostbyaddr  loadcheck      rlogin         uidgid
authuser       checkprog      gethostbyname  now            rsh
infotext       checkuser      gethostname    openssl        rshd
filestat       getservbyname  qrsh_starter   testsuidroot

Installation failed. Exit.



Expected results:
Should not abort

Additional info:
If I simply comment out the exit statement in "util/install_modules/inst_common.sh", the install succeeds.
Comment 1 Orion Poplawski 2012-03-14 16:50:07 EDT
I probably didn't notice this because I never run install_execd.  Why do you need to run it?
Comment 2 Juno Krahn 2012-03-14 17:36:15 EDT
From the README:
------------------------
- On execution hosts install gridengine-execd, then:

  cd /usr/share/gridengine
  ./install_execd

OR if you have a default install, you may be able to just do:

  chkconfig sge_execd on
  service sge_execd start
------------------------

From this, install_execd should be expected to work, even if it is not essential. One useful result is that it adds the exec host to the @allhosts group and the all.q queue.
Comment 3 Fedora Update System 2012-03-14 19:02:55 EDT
gridengine-6.2u5p2-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gridengine-6.2u5p2-7.fc16
Comment 4 Fedora Update System 2012-03-14 19:03:04 EDT
gridengine-6.2u5-10.fc15.1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gridengine-6.2u5-10.fc15.1
Comment 5 Fedora Update System 2012-03-17 19:36:18 EDT
Package gridengine-6.2u5p2-7.fc16.1:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gridengine-6.2u5p2-7.fc16.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4008/gridengine-6.2u5p2-7.fc16.1
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-03-25 23:58:40 EDT
gridengine-6.2u5-10.fc15.2 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-03-26 13:55:29 EDT
gridengine-6.2u5p2-7.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-03-26 14:01:21 EDT
gridengine-6.2u5-10.fc15.2 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.