Bug 80352 - kernel panic (and freezes) on newer compaq and hp laptops
kernel panic (and freezes) on newer compaq and hp laptops
Status: CLOSED DUPLICATE of bug 72387
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-12-24 16:51 EST by Fred T. Hamster
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Fred T. Hamster 2002-12-24 16:51:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
i recently purchased a compaq presario laptop, model 915us.  when booting the
install disks for redhat 8.0, one of two things will happen.  (1) i was trying
to reproduce the original problem recently and experienced a freeze-up on the
"welcome to redhat linux" page.  this happens with either the graphical or text
mode install.  this is newer behavior and perhaps resulted from having
partitions already set up on the hard drive or some other change since my
original install.  (2) however, the original kernel panic i was seeing from the
installer is still easily reproducible.  currently, i have to boot with the
following options: nomce nopcmcia nousb noisapnp.  if i do not, i will get a
kernel panic.  this happens on the default 8.0 kernel as well as the newest
version (2.4.18-19.8.0).  the kernel panic is reported as:
bank 3: b40000000000083b at 00000001fc0003b3
kernel panic unable to continue
if i use just noisapnp, then it gets stuck at "mounting usb filsystem".
if i use just noisapnp and nousb, then it crashes as above, just after "starting
pcmcia: yenta irq list 02f8, pci irq 10, socket status 300000006 [ok]."
this behavior seems exactly reproduced on a previous laptop that i gave up
on--this was an hp ze4125 model.
it seems that this kind of kernel panic severely limits the appeal of linux for
anyone who buys newer hardware, whatever the true cause of the problem.  on the
hp message boards, it was claimed that this is a bios bug that is fixed by newer
pcmcia-cs kernel support, but i have seen no linux release that can handle my
compaq laptop properly.  older models of compaq had no problem with any of this
so it seems to be a defect introduced by the merger with hp.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot redhat install disk
1. install redhat linux given the disabling flags above, then try booting
without the flags.

Actual Results:  kernel panic
total freeze during install

Expected Results:  a normal installation of redhat without kernel panics or freezes.

Additional info:

see description above.
Comment 1 Arjan van de Ven 2002-12-25 05:29:33 EST
does this laptop have an radeonIGP chipset ?
Comment 2 Fred T. Hamster 2002-12-26 00:44:42 EST
yes, yes it does.
currently i am just treating the radeon igp as a vesa card.
Comment 3 Arjan van de Ven 2002-12-26 12:08:00 EST
Bug 72387 has more info about getting linux to work on radeon IGP chipsets;
please look there. I'll mark this bug as a duplicate of that bug to keep all
info in one place.

*** This bug has been marked as a duplicate of 72387 ***
Comment 4 Fred T. Hamster 2002-12-27 18:51:33 EST
this is not just a radeon igp issue.
i have applied the pcmcia config.opts exclusion from bug 72387, and this makes
two of the extra flags (nopcmcia and nomce) no longer necessary.
however, i will still get a kernel panic if i do not include noisapnp.
and i still get a freeze mounting usb filesystem if i do not include nousb.
usb is a fairly important feature of the laptop which would be nice to have
working; is there a bug that addresses this issue for this series of laptops?
there is no isa bus on this machine (i would guess), so i don't need that,
although it's bad that it will cause a crash (as described above with the kernel
panic).  however, usb support seems essential to have a full featured linux laptop.
Comment 5 Arjan van de Ven 2002-12-27 19:03:21 EST
radeon igp is the entire chipset, not just the graphics chip. the noisapnp
appears needed because this chipset reacts rather violent to pnp probing... same
for the other issues ;(
Comment 6 Fred T. Hamster 2002-12-27 19:52:15 EST
ah, okay.  well, i cannot express (here, propriety prohibits it) my loathing for
compaq/hp and ATI at this point.  i think i shall write them a very dissatisfied

*** This bug has been marked as a duplicate of 72387 ***
Comment 7 franceschini stefano 2003-02-06 04:26:36 EST
i have the same problem with compaq evo n1005v 
there is the solution for this problem kerne panic with red aht 8.0
Comment 8 Red Hat Bugzilla 2006-02-21 13:50:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.