This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 803545 - lldb
lldb
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 20:55 EDT by MERCIER Jonathan
Modified: 2012-10-27 13:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 04:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description MERCIER Jonathan 2012-03-14 20:55:50 EDT
Recently lldb team as work to enable lldb build under linux, as llvm provides clang will be great to do same for lldb.

Thabnks a lot

Note llvm 3.1 come soon
Comment 1 MERCIER Jonathan 2012-06-18 05:17:18 EDT
any news?
Comment 2 Michel Alexandre Salim 2012-06-19 06:46:37 EDT
Hi Jonathan,

LLDB documentation does not mention Linux support yet, so I'm a bit hesitant about making it the default.

I need to reorganize the LLVM spec anyway -- need to find time to do that, so thanks for reminding me about this. I can make LLDB inclusion a build-time option, and you can test if it works for you -- how does that sound?
Comment 3 MERCIER Jonathan 2012-06-19 20:00:29 EDT
sound good :-)

thanks a lot for your works.
I have already in the past ask from LLVM mailling list to write a doc for linux but it is a bit slow in any case.
Comment 4 MERCIER Jonathan 2012-09-13 09:04:27 EDT
hi michel,
I see this bug with state Assigned . I would like to know what is the state ?

thanks a lot for your great job

kind regards
Comment 5 Michel Alexandre Salim 2012-10-24 04:39:11 EDT
Upstream still does not support Linux, and attempting to build from the latest trunk fails with type cast problems.

Please refrain from reopening this until there is proper Linux support for LLDB (or other LLVM technologies)
Comment 6 MERCIER Jonathan 2012-10-24 16:15:33 EDT
Thanks a lot for your try, i seen this how to http://lldb.llvm.org/build.html
Comment 7 Michel Alexandre Salim 2012-10-25 00:24:13 EDT
The instructions there are, sadly, wrong.

- configure --enable-libcpp does not make much sense since libcxx's (they don't call it consistently) website claims they only support OS X
- the CXXFLAGS=-std=c++11 causes build to immediately fail with GCC

Looks like one can only build this with clang. Let me check with the packaging committee if we can have LLVM/clang self-hosting itself
Comment 8 MERCIER Jonathan 2012-10-25 02:27:16 EDT
ok thanks i search in same time some information.
So, it seem the current lldb trunk break the build on linux but rev  166514 should works
Comment 9 Michel Alexandre Salim 2012-10-27 13:21:52 EDT
Without a patch to the spec and a mock build demonstrating that lldb actually builds, I don't have time to invest in this, sorry. Certainly not while upstream cannot even update the README, and the documentation barely mentions compiling with GCC.

Due to the critical use of LLVM to compile Mesa's LLVMpipe, we will not be switching to self-hosting LLVM and Clang anytime soon - unless someone wants to make it happen and is willing to take ownership of the switch. Until that happens, packaging LLDB will be a rather iffy proposition.

Note You need to log in before you can comment on or make changes to this bug.