Bug 803576 - Cursor positioning issue in English Typing Booster
Cursor positioning issue in English Typing Booster
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-european-table (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: anish
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 01:53 EDT by Ani Peter
Modified: 2016-07-31 21:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: ibus-european-table-1.1.6-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:28:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the cursor positioning issue (63.15 KB, image/png)
2012-03-15 01:53 EDT, Ani Peter
no flags Details
The cursor move automatically when selecting the candidate word from the look up window via press Up Down key. (69.51 KB, image/png)
2012-03-16 03:01 EDT, Lijun Li
no flags Details

  None (edit)
Description Ani Peter 2012-03-15 01:53:37 EDT
Created attachment 570171 [details]
Screenshot showing the cursor positioning issue

Description of problem:
While typing a word, after typing its last letter, instead of cursor being positioned after this last letter, it is still positioned before this letter. eg:- when I type space, after typing 'e', the cursor is positioned before 'e' instead of it being positioned after 'e'.

Version-Release number of selected component (if applicable):
english-typing-booster-0.0.2-1.fc17.noarch

How reproducible:
When typing such a word for the first time, once this word is committed, this positioning issue doesnt happen again.

Steps to Reproduce:
1. Open any editor, eg:- gedit
2. Type space and notice the cursor positioning after 'e'.
  
Actual results:
Cursor must be positioned after the last letter.

Expected results:
Cursor must be positioned before the last letter.

Additional info:
Comment 1 Lijun Li 2012-03-16 03:01:59 EDT
Created attachment 570510 [details]
The cursor move automatically when selecting the candidate word from the look up window via press Up Down key.
Comment 2 Lijun Li 2012-03-16 03:04:02 EDT
Verified the word 'beauty', the issue always reproduced, the cursor move automatically when selecting the candidate word from the look
up window via press Up Down key, not sure if the issue is by design or not.
Comment 3 Lijun Li 2012-03-16 03:18:54 EDT
Seems it is not an issue, it's the correct english words functions, so the cursor can move for your selecting the candidates word from the lookup window(ex. type 'baetty' for testing.)
Comment 4 Fedora Update System 2012-03-27 01:28:38 EDT
ibus-european-table-1.1.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-european-table-1.1.6-1.fc15
Comment 5 Fedora Update System 2012-03-27 01:29:17 EDT
ibus-european-table-1.1.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-european-table-1.1.6-1.fc16
Comment 6 Fedora Update System 2012-03-27 01:29:55 EDT
ibus-european-table-1.1.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-european-table-1.1.6-1.fc17
Comment 7 Fedora Update System 2012-03-28 01:53:45 EDT
Package ibus-european-table-1.1.6-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-european-table-1.1.6-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4755/ibus-european-table-1.1.6-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-04-18 15:28:23 EDT
ibus-european-table-1.1.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-04-18 15:29:21 EDT
ibus-european-table-1.1.6-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-04-18 19:02:58 EDT
ibus-european-table-1.1.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.