Bug 80359 - Extra USB mouse for laptops stopped working
Summary: Extra USB mouse for laptops stopped working
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 79578 79627
TreeView+ depends on / blocked
 
Reported: 2002-12-24 22:47 UTC by Warren Togami
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-31 09:45:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config generated by redhat-config-xfree86, PS/2 mouse (3.14 KB, text/plain)
2002-12-25 12:01 UTC, Warren Togami
no flags Details

Description Warren Togami 2002-12-24 22:47:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Red Hat 8.0 introduced automatic configuration of a USB mouse if you 
selected PS/2 mouse.  While it had one minor problem mentioned in Bug 79627 it
worked fairly well and was very useful for laptop users like me.  Unfortunately 
Phoebe does not seem to configure the extra hotplug USB mouse anymore. 

Version-Release number of selected component (if applicable):
Phoebe

How reproducible:
Always

Steps to Reproduce:
1. Configure PS/2 mouse
2. Plug in USB mouse

Actual Results:  
Doesn't work.

Expected Results:  
Extra USB mouse should work as hotplug device in X.

Comment 1 Bill Nottingham 2002-12-25 02:04:49 UTC
What does your /etc/X11/XF86Config look like?

Comment 2 Warren Togami 2002-12-25 12:01:01 UTC
Created attachment 88904 [details]
XF86Config generated by redhat-config-xfree86, PS/2 mouse

Comment 3 Mike A. Harris 2002-12-25 18:08:03 UTC
If you define multiple pointers as in the past, XFree86 works perfectly
just as expected.  I just tested this with a USB and PS/2 mouse plugged
into a single computer.  So this is not an XFree86 problem.

Reassigning to anaconda.

Comment 4 Warren Togami 2002-12-25 19:47:54 UTC
If that is so, it should be fixed in redhat-config-mouse too.


Comment 5 Jeremy Katz 2002-12-26 03:53:15 UTC
anaconda is setting the config file up right, so this is the kernel not
registering the hot plug events

Comment 6 Pete Zaitcev 2002-12-26 19:22:32 UTC
I would like to see the "lsmod" output, taken afther the USB mouse
is plugged in (but did not work). At a guess, you'll see hid
but not mousedev. Hotplug loads hid, and it's hard to break.
But let's be safe.

In 8.0, initscripts loaded mousedev, but I suspect Notting threw this out,
because "new" modutils are supposed to support the char-major-13-32 alias.

Requestor, please attach the following files:
rpm -qa >/tmp/rpm-a.txt  # Need to know what initscripts and modutils are used
/proc/modules            # Taken after the mouse connected
/etc/modules.conf        # Checking for char-major-13-32
/proc/version            # I'll look if autoload for #13 regressed in it
/etc/rc.d/rc.sysinit     # To diff with old one (mousedev load removal)

This ought to be enough to figure it out.
Please attach them just like XF86Config, do not drop into comments box!


Comment 7 Arjan van de Ven 2002-12-26 19:30:05 UTC
Pete: My laptop also no longer likes ANY usb devices with the phoebe kernel..
somehting smells fishy in this areay...

Comment 8 Pete Zaitcev 2002-12-26 19:44:02 UTC
OK, I'm taking this then.


Comment 9 Warren Togami 2003-01-31 09:45:46 UTC
Hot plug USB mouse seems to work in Phoebe2.  Close?

Comment 10 Bill Nottingham 2003-01-31 16:02:21 UTC
Duh, yeah, hotplug was broken with the initial Phoebe kernel.


Note You need to log in before you can comment on or make changes to this bug.