Bug 803633 - [virtio-win][balloon]balloon does not work after s3 or s4
[virtio-win][balloon]balloon does not work after s3 or s4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Reopened
Depends On:
Blocks: 720669 761491
  Show dependency treegraph
 
Reported: 2012-03-15 06:11 EDT by Mike Cao
Modified: 2013-02-21 05:38 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:38:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-03-15 06:11:43 EDT
Description of problem:


Version-Release number of selected component (if applicable):
virtio-win-prewhql-23
# uname -r
2.6.32-252.el6.x86_64
[root@amd-2376-32-1 test]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.248.el6rhev.x86_64


How reproducible:
100%

Steps to Reproduce:
1.start guest w/ qxl
CLI:/usr/libexec/qemu-kvm -M rhel6.3.0 -enable-kvm -m 8192 -smp 4,sockets=4,cores=1,threads=1 -name win2k8-R2 -uuid e2eaca3e-e764-f57b-22f0-74f4ab8c4965 -monitor stdio -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/test/win2k8r2,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/root/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:15:af:6a,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -spice port=5910,disable-ticketing -vga qxl -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5  -bios /bios-tttt.bin
2.sleep guest 
3.wakeup guest via keyboard
4(qemu)balloon 1024
  
Actual results:
balloon does not work

Expected results:
balloon should work

Additional info:
1.After disable virtio balloon driver ,then re-enable it ,the driver could use .
Comment 2 Joy Pu 2012-03-22 08:08:42 EDT
Find the similar problem in S4. When the memory parameter in command line is more than host memory After S4 in guest the memory status will keep the same as before S4, but in monitor it will report as the value before memory ballooning. At this point if you do memory balloon in a value smaller than the memory shows is used in guest, balloon will failed. But if you set a value is bigger than that it will success and will work again. Test this in Win7 guest.
Comment 3 Ronen Hod 2012-03-25 19:23:23 EDT
Vadim and I discussed this bug. On the one hand it is a blocker for Windows ballooning with S3, but on the other hand we can live without it. We will see how we are with the time.
Comment 4 Vadim Rozenfeld 2012-04-04 06:21:30 EDT
(In reply to comment #2)
> Find the similar problem in S4. When the memory parameter in command line is
> more than host memory After S4 in guest the memory status will keep the same as
> before S4, but in monitor it will report as the value before memory ballooning.
> At this point if you do memory balloon in a value smaller than the memory shows
> is used in guest, balloon will failed. But if you set a value is bigger than
> that it will success and will work again. Test this in Win7 guest.

Qemu doesn't keep balloon size persistent between S0-S4-S0 sequences.
Best regards,
Vadim.
Comment 5 Vadim Rozenfeld 2012-04-08 11:56:05 EDT
please re-check with the drivers from build-25
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/25/win/virtio-win-prewhql-0.1.zip
Comment 8 Mike Cao 2012-04-09 03:56:12 EDT
Tried w/ virtio-win-prewhql-25

steps same as comment #0

Actual Results:
balloon still does not work after s3

Based on above ,re-assign this issue .
Comment 9 Vadim Rozenfeld 2012-04-09 05:12:38 EDT
(In reply to comment #8)
> Tried w/ virtio-win-prewhql-25
> 
> steps same as comment #0
> 
> Actual Results:
> balloon still does not work after s3
> 
> Based on above ,re-assign this issue .

Hi Mike,
Can you reproduce this problem on Win7 32-bit?
Could you also try reproducing this problem on W2K8R2
VM, running with less amount of memory (say -m 4096)?

Thank you,
Vadim.
Comment 11 Mike Cao 2012-04-11 03:04:23 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > Tried w/ virtio-win-prewhql-25
> > 
> > steps same as comment #0
> > 
> > Actual Results:
> > balloon still does not work after s3
> > 
> > Based on above ,re-assign this issue .
> 
> Hi Mike,
> Can you reproduce this problem on Win7 32-bit?
> Could you also try reproducing this problem on W2K8R2
> VM, running with less amount of memory (say -m 4096)?
> 
> Thank you,
> Vadim.

Hi Vadim

Very weird 
I tried more that 10 times and can *not* reproduce it bug today ,both on -24 and -25.
But I am sure I hit it when I report the bug .

Can I move this bug to verified or close works for me ?

Best Regards,
Mike
Comment 12 Vadim Rozenfeld 2012-04-11 03:16:06 EDT
(In reply to comment #11)
> (In reply to comment #9)
> > (In reply to comment #8)
> > > Tried w/ virtio-win-prewhql-25
> > > 
> > > steps same as comment #0
> > > 
> > > Actual Results:
> > > balloon still does not work after s3
> > > 
> > > Based on above ,re-assign this issue .
> > 
> > Hi Mike,
> > Can you reproduce this problem on Win7 32-bit?
> > Could you also try reproducing this problem on W2K8R2
> > VM, running with less amount of memory (say -m 4096)?
> > 
> > Thank you,
> > Vadim.
> 
> Hi Vadim
> 
> Very weird 
> I tried more that 10 times and can *not* reproduce it bug today ,both on -24
> and -25.
> But I am sure I hit it when I report the bug .
> 
> Can I move this bug to verified or close works for me ?
> 
> Best Regards,
> Mike

Hi Mike,
Let's close it as works_for_me if you cannot reproduce it any more.
In any case balloon will need to be retested completely in 6.4
best regards,
Vadim.
Comment 13 Mike Cao 2012-04-11 03:25:12 EDT
(In reply to comment #12)
> (In reply to comment #11)
> > (In reply to comment #9)
> > > (In reply to comment #8)
> > > > Tried w/ virtio-win-prewhql-25
> > > > 
> > > > steps same as comment #0
> > > > 
> > > > Actual Results:
> > > > balloon still does not work after s3
> > > > 
> > > > Based on above ,re-assign this issue .
> > > 
> > > Hi Mike,
> > > Can you reproduce this problem on Win7 32-bit?
> > > Could you also try reproducing this problem on W2K8R2
> > > VM, running with less amount of memory (say -m 4096)?
> > > 
> > > Thank you,
> > > Vadim.
> > 
> > Hi Vadim
> > 
> > Very weird 
> > I tried more that 10 times and can *not* reproduce it bug today ,both on -24
> > and -25.
> > But I am sure I hit it when I report the bug .
> > 
> > Can I move this bug to verified or close works for me ?
> > 
> > Best Regards,
> > Mike
> 
> Hi Mike,
> Let's close it as works_for_me if you cannot reproduce it any more.
> In any case balloon will need to be retested completely in 6.4
> best regards,
> Vadim.

Yes ,We will do it .

Close this bug as I can not reproduce it 

Mike
Comment 14 Qunfang Zhang 2012-04-19 02:02:39 EDT
Hi, Vadim
I hit this problem again with virtio-win-prewhql-26 with win7-64. After either S3 or S4, balloon will not work anymore. So re-open it.

CLI:
/usr/libexec/qemu-kvm -M rhel6.3.0 -cpu Conroe -enable-kvm -m 2G -smp 2,sockets=1,cores=2,threads=1 -name win7-64 -uuid 3ab85f83-0a82-4aa8-9d73-01df056123ec -rtc base=localtime,driftfix=slew -drive file=/home/win7-64-virtio.raw,if=none,id=drive-virtio-disk0,format=raw,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,id=net0,mac=00:1a:2a:42:10:69,bus=pci.0 -boot c -drive file=/usr/share/virtio-win/virtio-win-1.4.0.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -spice port=5930,disable-ticketing -vga qxl -global qxl-vga.vram_size=33554432  -qmp tcp:0:4444,server,nowait -bios /usr/share/seabios/bios-pm.bin  -chardev socket,path=/tmp/qzhang-test,server,nowait,id=isa1 -device isa-serial,chardev=isa1,id=isa-serial1 -usb -device usb-tablet,id=input0 -device virtio-balloon-pci,id=balloon0,bus=pci.0 -monitor stdio

Packages tested:
kernel-2.6.32-262.el6.x86_64
qemu-kvm-0.12.1.2-2.275.el6.x86_64
seabios-0.6.1.2-18.el6.x86_64
virtio-win-prewhql-26
Comment 17 Qunfang Zhang 2012-06-21 05:09:46 EDT
Still can reproduce with the Comment 14 command line with win7-64 guest.
Tested with virtio-win-prewhql-29 and also the signed virtio-win-1.5.2, both can reproduce.

As it can not be reproduce on bcao's host, so update my host cpu info:

processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz
stepping	: 10
cpu MHz		: 2826.233
cache size	: 6144 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 3
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dts tpr_shadow vnmi flexpriority
bogomips	: 5652.46
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:
Comment 18 Vadim Rozenfeld 2012-06-21 07:24:24 EDT
(In reply to comment #17)
> Still can reproduce with the Comment 14 command line with win7-64 guest.
> Tested with virtio-win-prewhql-29 and also the signed virtio-win-1.5.2, both
> can reproduce.

Hi Qunfang,

Will it be possible to recheck virtio-win-prewhql-29 on a freshly installed
Win7-32 quest?

Thank you,
Vadim.
Comment 19 Qunfang Zhang 2012-06-24 23:15:16 EDT
(In reply to comment #18)
> (In reply to comment #17)
> > Still can reproduce with the Comment 14 command line with win7-64 guest.
> > Tested with virtio-win-prewhql-29 and also the signed virtio-win-1.5.2, both
> > can reproduce.
> 
> Hi Qunfang,
> 
> Will it be possible to recheck virtio-win-prewhql-29 on a freshly installed
> Win7-32 quest?
> 
> Thank you,
> Vadim.

Hi, Vadim
Just re-installed a fresh win7-32 guest and re-test with the virtio-win-prewhql-29. Still can reproduce this issue.

Regards,
Qunfang
Comment 20 Mike Cao 2012-06-25 01:02:57 EDT
Based on comment #17 and #19 ,re-assign this issue .

BTW, this can not be reproduced on my hosts .which hardware might it be related ?
Comment 21 Vadim Rozenfeld 2012-06-25 03:27:59 EDT
(In reply to comment #20)
> Based on comment #17 and #19 ,re-assign this issue .
> 
> BTW, this can not be reproduced on my hosts .which hardware might it be
> related ?

Qunfang, Mike
Can you please double check that
you are using identical kvm, qemu, 
and bios components?

Thank you,
Vadim.
Comment 22 Mike Cao 2012-06-26 01:16:17 EDT
(In reply to comment #21)
> (In reply to comment #20)
> > Based on comment #17 and #19 ,re-assign this issue .
> > 
> > BTW, this can not be reproduced on my hosts .which hardware might it be
> > related ?
> 
> Qunfang, Mike
> Can you please double check that
> you are using identical kvm, qemu, 
> and bios components?
> 
> Thank you,
> Vadim.

Mine:

2.6.32-274.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
seabios-0.6.1.2-19.el6.x86_64
vgabios-0.6b-3.6.el6.noarch
Comment 23 Qunfang Zhang 2012-06-26 01:21:39 EDT
Hi, Vadim
All the components I used are the same as Mike's as above comment.
Comment 24 Ronen Hod 2012-07-10 05:34:35 EDT
Moving to RHEL6.5, as we have too many more urgent issues.
Comment 25 Mike Cao 2012-07-25 01:54:34 EDT
Reproduced this issue virtio-win-prewhql-30 ,
If power management is officially supported in RHEL6.4 ,then I think this bug should be fixed in current release .
Comment 26 Vadim Rozenfeld 2012-09-10 03:55:49 EDT
Hi Mike,
Could you please try the latest drivers from build 35
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/35/win/virtio-win-prewhql-0.1.zip ?

Thank you,
Vadim.
Comment 27 dawu 2012-09-13 02:47:34 EDT
Reproduce this bug on virtio-win-prewhql-30,tested this bug on virtio-win-prewhql-35 with following steps:

environment:
virtio-win-prewhql-35
kernel-2.6.32-301.el6.x86_64
qemu-kvm-0.12.1.2-2.307.el6.x86_64

1. Start guest with CLI:
/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k8-R2.qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup0,downscript=no -device e1000,netdev=hostnet0,mac=00:10:4a:1b:78:19,bus=pci.0,addr=0x4 -uuid 1a93c322-02df-4c36-910b-d80d0a09361c -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-R2-balloon,server,nowait -mon chardev=111a,mode=readline -name win2k8-R2 -device virtio-balloon-pci,addr=0x5,bus=pci.0  -spice disable-ticketing,port=5931 -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio -drive file=en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,media=cdrom,id=cdrom,if=none -device ide-drive,drive=cdrom,bootindex=1

2.sleep guest 
3.wakeup guest via keyboard
4(qemu)balloon 1024

Actual Results:
on version virtio-win-prewhql-35,balloon still does not work after s3/s4.

Based on above ,this issue haven't fixed yet,reassign this bug.
Comment 28 dawu 2012-11-01 23:18:16 EDT
Tested this bug on win2k3-32 with virtio-win-prewhql-43 on rhel6.4 tree, this issue does not reproduce.

Steps:
1. Start guest with CLI:
/usr/libexec/qemu-kvm -M rhel6.4.0 -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2k3-32.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup0 -device e1000,netdev=hostnet0,mac=00:10:16:23:78:01,bus=pci.0,addr=0x4 -uuid 2628a05e-3dbf-4915-9362-861309b05160 -rtc base=localtime -no-kvm-pit-reinjection -monitor stdio -name win2k3-32 -spice port=5931,disable-ticketing -vga qxl  -chardev socket,id=111a,path=/tmp/monitor-win2k3-32,server,nowait -mon chardev=111a,mode=readline -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -device virtio-balloon-pci,addr=0x5,bus=pci.0,id=balloon0

2.S3 or S4
3.Resume guest
4.(qemu)balloon 1024

Actual result:
Balloon can work without any error.

Thanks
Best Regards,
Dawn
Comment 29 Mike Cao 2013-01-04 00:53:23 EST
Based on comment #28, This issue has been fixed in RHEL6.4.0 
Move back to rhel6.4.0
Comment 31 errata-xmlrpc 2013-02-21 05:38:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.