Bug 803635 - Update overrides existing configurations
Summary: Update overrides existing configurations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nginx
Version: el6
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jeremy Hinegardner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-15 10:19 UTC by Anonymous account
Modified: 2012-12-20 15:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-20 15:41:55 UTC
Type: ---


Attachments (Terms of Use)

Description Anonymous account 2012-03-15 10:19:51 UTC
Description of problem:
The recent update to version 1.0.12-1 contains the configuration /etc/nginx/conf.d/default.conf which has a "server_name  _;" directive. If your current nginx setup uses "server_name  _;" too, the default.conf can override it, depending on the filenames of your configs in conf.d.

Nginx gives a warning during start, but if the update is part of a larger update requiring a reboot, this goes unnoticed. As a result, all websites will display the default "nginx on epel" website until the default.conf is removed and nginx is reloaded.

Removing/Renaming default.conf only helps until the next update because the file will then be added again.

Version-Release number of selected component (if applicable):
from: nginx-0.8.54-1.el6.i686
to: nginx-1.0.12-1.el6.x86_64

How reproducible:
Update from 0.8.54 to 1.0.12

Steps to Reproduce:
1. Install 0.8.54
2. Add /etc/nginx/conf.d/z.conf containing "server_name  _;" server block
3. Update to 1.0.12 and restart nginx or reboot
  
Actual results:
The new default.conf overrides z.conf

Expected results:
No overridden website configs

Additional info:

Comment 1 Jamie Nguyen 2012-03-15 10:25:59 UTC
You can uncomment the contents of default.conf and it will not be overwritten on update. Instead, a default.conf.rpmnew will be created (which can be ignored).

Comment 2 Anonymous account 2012-03-16 09:17:48 UTC
Agreed, but it's rather annoying when an update modifies the working configuration and leaves the service not working as expected.

Comment 3 Fedora Update System 2012-10-28 15:46:46 UTC
nginx-1.2.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nginx-1.2.4-1.fc18

Comment 4 Jamie Nguyen 2012-10-28 16:40:46 UTC
I have centralized configuration into nginx.conf, which is the upstream default. In other words, I have removed default.conf/ssl.conf/virtual.conf.

From f18 and el7 onwards, you should no longer have this problem.

I chose not to fix this for el6, f17, f16 as deprecating the separate configuration files within conf.d/ could result in unexpected downtime: after upgrading nginx, those files are all moved to filename.rpmsave, regardless of whether they have been edited or not, and so the configuration of the web server may be unintentionally broken.

Comment 5 Fedora Update System 2012-10-29 18:14:16 UTC
Package nginx-1.2.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nginx-1.2.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17160/nginx-1.2.4-1.fc18
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-12-20 15:41:57 UTC
nginx-1.2.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.