Bug 803644 - ISE - Adding virtualization entitlement to a system without base channel
ISE - Adding virtualization entitlement to a system without base channel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Lukas Pramuk
:
Depends On:
Blocks: sat550-lowbug
  Show dependency treegraph
 
Reported: 2012-03-15 06:45 EDT by Lukas Pramuk
Modified: 2012-09-21 05:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 05:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Pramuk 2012-03-15 06:45:26 EDT
Description of problem:
WebUI: You cannot add virtualization entitlement to a system which has no base channel set. It will cause ISE (500)

Version-Release number of selected component (if applicable):
Satellite 5.4.1
spacewalk-backend-1.2.13-66.el6sat.noarch
spacewalk-backend-iss-export-1.2.13-66.el6sat.noarch
spacewalk-selinux-1.2.1-5.el6sat.noarch
spacewalk-base-1.2.7-21.el6sat.noarch
spacewalk-java-oracle-1.2.39-115.el6sat.noarch
spacewalk-backend-sql-oracle-1.2.13-66.el6sat.noarch
spacewalk-reports-1.2.2-4.el6sat.noarch
spacewalk-utils-1.2.1-16.el6sat.noarch
spacewalk-backend-config-files-common-1.2.13-66.el6sat.noarch
spacewalk-backend-package-push-server-1.2.13-66.el6sat.noarch
spacewalk-monitoring-selinux-1.1.1-3.el6sat.noarch
spacewalk-admin-1.2.4-3.el6sat.noarch
spacewalk-search-1.2.3-4.el6sat.noarch
spacewalk-java-config-1.2.39-115.el6sat.noarch
spacewalk-backend-libs-1.2.13-66.el6sat.noarch
spacewalk-dobby-1.2.7-21.el6sat.noarch
spacewalk-pxt-1.2.7-21.el6sat.noarch
spacewalk-backend-server-1.2.13-66.el6sat.noarch
spacewalk-backend-app-1.2.13-66.el6sat.noarch
spacewalk-backend-config-files-1.2.13-66.el6sat.noarch
spacewalk-backend-iss-1.2.13-66.el6sat.noarch
spacewalk-monitoring-1.1.1-1.el6sat.noarch
spacewalk-sniglets-1.2.7-21.el6sat.noarch
spacewalk-certs-tools-1.1.1-2.el6sat.noarch
spacewalk-backend-sql-1.2.13-66.el6sat.noarch
spacewalk-backend-xmlrpc-1.2.13-66.el6sat.noarch
spacewalk-schema-1.2.21-16.el6sat.noarch
spacewalk-backend-config-files-tool-1.2.13-66.el6sat.noarch
spacewalk-backend-xp-1.2.13-66.el6sat.noarch
spacewalk-setup-1.2.6-11.el6sat.noarch
spacewalk-common-1.2.1-4.el6sat.noarch
spacewalk-ssl-cert-check-2.0-1.el6sat.noarch
spacewalk-html-1.2.7-21.el6sat.noarch
spacewalk-backend-xml-export-libs-1.2.13-66.el6sat.noarch
spacewalk-backend-applet-1.2.13-66.el6sat.noarch
spacewalk-oracle-1.2.1-4.el6sat.noarch
spacewalk-java-lib-1.2.39-115.el6sat.noarch
spacewalk-grail-1.2.7-21.el6sat.noarch
spacewalk-config-1.2.2-7.el6sat.noarch
spacewalk-backend-tools-1.2.13-66.el6sat.noarch
spacewalk-backend-upload-server-1.2.13-66.el6sat.noarch
spacewalk-base-minimal-1.2.7-21.el6sat.noarch
spacewalk-java-1.2.39-115.el6sat.noarch
spacewalk-setup-jabberd-1.2.1-2.el6sat.noarch
spacewalk-taskomatic-1.2.39-115.el6sat.noarch

How reproducible: 100%

Steps to Reproduce:
1. prepare a system that has no base channel set
2. On WebUI navigate to System - choose that system
3. Switch to Details - Properties tab
4. set Virtualization Entitlement check box on 
5. press Update properties button
6. get Internal Server Error
  
Actual results:
After pressing "Update properties" button, ISE occurs, Virtualization Entitlement not added

Expected results:
After pressing "Update properties" button, Virtualization Entitlement is added, the same warning can be displayed, as is for a system with only custom channel.
"Could not automatically subscribe the system to the RHEL Virtualization Channel. This channel contains packages required for virtualization. This is most likely caused by a lack of channel entitlements."
Comment 1 Lukas Pramuk 2012-03-15 06:49:56 EDT
catalina.out meow ;-)

2012-03-15 06:48:18,176 [TP-Processor8] WARN  org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class java.lang.NullPointerException
2012-03-15 06:48:18,176 [TP-Processor8] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
javax.servlet.ServletException: java.lang.NullPointerException
	at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:520)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:427)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:228)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:99)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:462)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:117)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.obtainContent(SiteMeshFilter.java:129)
	at com.opensymphony.sitemesh.webapp.SiteMeshFilter.doFilter(SiteMeshFilter.java:77)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:736)
Caused by: 
java.lang.NullPointerException
	at com.redhat.rhn.manager.system.SystemManager.setupSystemForVirtualization(SystemManager.java:1674)
	at com.redhat.rhn.manager.system.SystemManager.entitleServer(SystemManager.java:1603)
	at com.redhat.rhn.manager.system.SystemManager.entitleServer(SystemManager.java:1557)
	at com.redhat.rhn.frontend.action.systems.sdc.SystemDetailsEditAction.checkVirtEntitlements(SystemDetailsEditAction.java:262)
	at com.redhat.rhn.frontend.action.systems.sdc.SystemDetailsEditAction.processSubmission(SystemDetailsEditAction.java:204)
	at com.redhat.rhn.frontend.action.systems.sdc.SystemDetailsEditAction.execute(SystemDetailsEditAction.java:99)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:425)
	... 40 more
Comment 2 Tomas Lestach 2012-03-16 10:05:16 EDT
spacewalk.git: 339e648b02bf23ec444cb07253dd09f5ad9724e0
Comment 4 Tomas Lestach 2012-05-22 10:19:26 EDT
Moving ON_QA
Comment 6 Clifford Perry 2012-09-21 05:35:36 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Note You need to log in before you can comment on or make changes to this bug.