Bug 803650 - inspect-is-live return false when inspection results should be true
inspect-is-live return false when inspection results should be true
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 07:08 EDT by Yuyu Zhou
Modified: 2015-04-20 04:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-20 04:45:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuyu Zhou 2012-03-15 07:08:21 EDT
Description of problem:
As the document says, If "inspect_get_format" returns "installer" (this is an install disk), then this returns true if a live image was detected on the disk. But it returns false actually.

Version-Release number of selected component (if applicable):
libguestfs-1.16.10-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. download a valid installation DVD
2. Inspect the DVD iso as following:
# guestfish
$ add-ro RHEL6.2-20111117.0-Workstation-x86_64-Live.iso
$ run
$ inspect-os
/dev/vda
$ inspect-get-format /dev/vda
installer
$ inspect-is-live /dev/vda
false

Actual results:
$ inspect-is-live /dev/vda
false

Expected results:
$ inspect-is-live /dev/vda
true

Additional info:
Also tested with FRHEL6.2-20111117.0-Workstation-i386-Live.isoe,dora-13-i686-Live.iso && Fedora-16-x86_64-Live-Desktop.iso, none of them works as expected.
Comment 1 Yuyu Zhou 2012-03-16 04:52:40 EDT
Correct some typo, sorry for the inconvenience.

Additional info:
Also tested with
RHEL6.2-20111117.0-Workstation-i386-Live.iso,Fedora-13-i686-Live.iso &&
Fedora-16-x86_64-Live-Desktop.iso, none of them works as expected.
Comment 2 Richard W.M. Jones 2012-03-16 06:47:04 EDT
I'm going to defer all of this installer inspection code to 6.4.
There seem to be many bugs, and most likely upstream we will
switch to using ISO metadata detection (from libosinfo) as a
more reliable way to do this.  That is not implemented yet
upstream and is too large a change for 6.3.
Comment 4 RHEL Product and Program Management 2012-07-10 02:19:25 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 20:01:49 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Richard W.M. Jones 2012-08-10 09:04:27 EDT
At this point, integration with libosinfo is likely to be
a RHEL 7 issue.  However setting RHEL 6.5 flags just in case.
Comment 7 Richard W.M. Jones 2012-11-29 13:29:47 EST
The upstream fix is:
https://github.com/libguestfs/libguestfs/commit/90e7981082a2685b235724a6dd9b737cb90fe553

This is RHEL 7 material since it involves libosinfo
integration.
Comment 12 Richard W.M. Jones 2015-04-20 04:45:09 EDT
I'm closing this bug as WONTFIX because:

(a) Not reported or affecting any customers

(b) Other tools (libosinfo) give the same or better information

(c) Has been around for years without attracting enough interest to fix

Note You need to log in before you can comment on or make changes to this bug.