Bug 803657 - [RFE] inspect-is-netinst : support more distributions
[RFE] inspect-is-netinst : support more distributions
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 07:28 EDT by Yuyu Zhou
Modified: 2015-04-20 04:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-20 04:45:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuyu Zhou 2012-03-15 07:28:14 EDT
Description of problem:
As the document says: If "inspect_get_format" returns "installer" (this is an install disk), then this returns true if the disk is a network installer, ie. not a self-contained install CD but one which is likely to require network access to complete the install. But it returns false actually.

Version-Release number of selected component (if applicable):
libguestfs-1.16.10-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. download a  not a self-contained install CD, such as boot.iso for RHEL
2. Inspect the DVD iso as following:
# guestfish
$ add-ro boot.iso
$ run
$ inspect-os
/dev/vda
$ inspect-get-format /dev/vda
installer
$ inspect-is-netinst /dev/vda
false

Actual results:
$ inspect-is-netinst /dev/vda
false

Expected results:
$ inspect-is-netinst /dev/vda
true

Additional info:
Following distros tested:
+---------------------------------------------------------+
|     RHEL5.8    |    RHEL6.2    |ubuntu11.10|Debian-6.0.4|
+----------------+---------------+-----------+------------+
| i386 | x86_64  | i386 | x86_64 |   x86_64  |  x86_64    | 
+------+---------+------+--------+-----------+------------+
| FAIL |  FAIL   | FAIL |  FAIL  |    FAIL   |    PASS    |
+------+---------+------+--------+-----------+------------+
Comment 1 Qixiang Wan 2012-03-15 07:37:13 EDT
qa_ack+. Seems now it only work with the images which has the content of "not_complete" in $ISO/.disk/cd_type file. Future feature to support more distributions.
Comment 2 RHEL Product and Program Management 2012-07-10 02:19:20 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 20:01:54 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Richard W.M. Jones 2012-08-10 09:05:36 EDT
No upstream fix for this.  Likely we'll change the
upstream code to use libosinfo for CD/installer
detection, and that will happen in time for RHEL 7.
Setting RHEL 6.5 flags just in case we rebase.
Comment 5 Richard W.M. Jones 2012-11-29 13:33:21 EST
Upstream I have started to integrate libosinfo
database information:
https://github.com/libguestfs/libguestfs/commit/90e7981082a2685b235724a6dd9b737cb90fe553

However the current libosinfo database does not
contain information about whether a disk is
a network install disk, meaning that this bug
is not directly fixed yet.

In any case it's a RHEL 7 issue.
Comment 8 Pino Toscano 2013-12-13 12:28:06 EST
After a quick glance, it seems there's no way to detect RHEL/CentOS or Ubuntu netinst CDs just by looking at their file contents (unlike Debian CDs which have that information in /.disk/cd_type).

Maybe RHEL installation disk images could start getting a similar file indicating their type...
Comment 9 Richard W.M. Jones 2013-12-15 16:21:35 EST
(In reply to Pino Toscano from comment #8)
> After a quick glance, it seems there's no way to detect RHEL/CentOS or
> Ubuntu netinst CDs just by looking at their file contents (unlike Debian CDs
> which have that information in /.disk/cd_type).

It's likely to be possible using the ISO volume information.

The libosinfo project has been collecting this info in their
database, and libguestfs is *supposed* to be able to use it.
See:
https://github.com/libguestfs/libguestfs/blob/master/src/osinfo.c

(This might not be working, I've not tried it in a while and
it's another reason why we could do with having regression tests
for real inspection)
Comment 12 Richard W.M. Jones 2015-04-20 04:45:11 EDT
I'm closing this bug as WONTFIX because:

(a) Not reported or affecting any customers

(b) Other tools (libosinfo) give the same or better information

(c) Has been around for years without attracting enough interest to fix

Note You need to log in before you can comment on or make changes to this bug.