Bug 80374 - Kernel (2.4.20-2.2(smp)) panic on mounting .
Kernel (2.4.20-2.2(smp)) panic on mounting .
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
phoebe
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-12-25 06:02 EST by Ivo Sarak
Modified: 2007-03-26 23:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-26 06:28:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ASUS A7M266D ACPIdmp (39.98 KB, text/plain)
2003-01-02 16:00 EST, Ivo Sarak
no flags Details
ASUS A7M266D DMIdecode (7.71 KB, text/plain)
2003-01-02 16:02 EST, Ivo Sarak
no flags Details

  None (edit)
Description Ivo Sarak 2002-12-25 06:02:43 EST
Description of problem: 
 
After upgrade from RedHat 8.0 to RedHat 8.0.92 I get kernel panic 
with kernel 2.4.20-2.2smp or 2.4.20-2.2: 
 
Freeing initrd memory: 65k freed 
VFS: Mounted root (ext2 filesystem). 
Red Hat nash version 3.4.28 starting 
Mounting /proc filesystem 
Creating block devices 
Creating root device 
Mounting root filesystem 
mount: error 19 mounting ext3 
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2 
umount /initrd/proc failed: 2 
Freeing unused kernel memory: 152k freed 
Kernel panic: No init found. Try passing init= option to kernel. 
 
 
Same system but with kernel 2.4.18-19.8.0smp or 2.4.18-19.8.0: 
 
Freeing initrd memory: 131k freed 
VFS: Mounted root (ext2 filesystem). 
Journalled Block Device driver loaded 
kjournald starting.  Commit interval 5 seconds 
EXT3-fs: mounted filesystem with ordered data mode. 
Freeing unused kernel memory: 196k freed 
 
(And everything goes on normally...) 
 
 
How reproducible: 
 
Every time. 
 
Steps to Reproduce: 
 
Upgrade from Red Hat 8.0 to RedHat Public Beta Phoebe. 
 
Actual results: 
 
Kernel panic! 
 
Expected results: 
 
No kernel panic. 
 
Additional info: 
 
 
[root@haskaa boot]# df 
Filesystem           1K-blocks      Used Available Use% Mounted on 
/dev/hda5             15124868  11013876   3342688  77% / 
/dev/hda1                69973     44412     21948  67% /boot 
none                    256704         0    256704   0% /dev/shm 
 
[root@haskaa boot]# ls -la 
total 40071 
drwxr-xr-x    4 root     root         3072 Dec 25 12:09 . 
drwxr-xr-x   31 root     root         4096 Dec 25 12:37 .. 
-rw-r--r--    1 root     root         5824 Dec 12 20:39 boot.b 
-rw-r--r--    1 root     root          612 Dec 12 20:39 chain.b 
-rw-r--r--    1 root     root        42211 Nov 14 06:12 config-2.4.18-18.8.0 
-rw-r--r--    1 root     root        42714 Nov 14 07:01 
config-2.4.18-18.8.0debug 
-rw-r--r--    1 root     root        42151 Nov 14 05:47 
config-2.4.18-18.8.0smp 
-rw-r--r--    1 root     root        42200 Dec 12 11:56 config-2.4.18-19.8.0 
-rw-r--r--    1 root     root        42703 Dec 12 12:36 
config-2.4.18-19.8.0debug 
-rw-r--r--    1 root     root        42140 Dec 12 11:28 
config-2.4.18-19.8.0smp 
-rw-r--r--    1 root     root        43792 Dec 20 19:58 config-2.4.20-2.2 
-rw-r--r--    1 root     root        43732 Dec 20 19:30 config-2.4.20-2.2smp 
drwxr-xr-x    2 root     root         1024 Dec 25 05:55 grub 
-rw-r--r--    1 root     root       130804 Nov 18 00:42 
initrd-2.4.18-18.8.0debug.img 
-rw-r--r--    1 root     root       132976 Nov 18 00:42 
initrd-2.4.18-18.8.0.img 
-rw-r--r--    1 root     root       136149 Nov 18 00:42 
initrd-2.4.18-18.8.0smp.img 
-rw-r--r--    1 root     root       132737 Dec 23 08:01 
initrd-2.4.18-19.8.0debug.img 
-rw-r--r--    1 root     root       130295 Dec 23 08:01 
initrd-2.4.18-19.8.0.img 
-rw-r--r--    1 root     root       134354 Dec 23 08:01 
initrd-2.4.18-19.8.0smp.img 
-rw-r--r--    1 root     root        65710 Dec 25 05:29 
initrd-2.4.20-2.2.img 
-rw-r--r--    1 root     root        67298 Dec 25 05:29 
initrd-2.4.20-2.2smp.img 
-rw-r--r--    1 root     root          483 Sep 14 01:47 kernel.h 
drwxr-xr-x    2 root     root         1024 Nov 13  2001 lost+found 
-rw-r--r--    1 root     root        23108 Dec 16 23:36 message 
-rw-r--r--    1 root     root        21282 Dec 16 23:36 message.ja 
lrwxrwxrwx    1 root     root           22 Dec 25 05:29 module-info -> 
module-info-2.4.20-2.2 
-rw-r--r--    1 root     root        15436 Nov 14 06:12 
module-info-2.4.18-18.8.0 
-rw-r--r--    1 root     root        15436 Nov 14 07:01 
module-info-2.4.18-18.8.0debug 
-rw-r--r--    1 root     root        15436 Nov 14 05:47 
module-info-2.4.18-18.8.0smp 
-rw-r--r--    1 root     root        15436 Dec 12 11:56 
module-info-2.4.18-19.8.0 
-rw-r--r--    1 root     root        15436 Dec 12 12:36 
module-info-2.4.18-19.8.0debug 
-rw-r--r--    1 root     root        15436 Dec 12 11:28 
module-info-2.4.18-19.8.0smp 
-rw-r--r--    1 root     root        15436 Dec 20 19:58 
module-info-2.4.20-2.2 
-rw-r--r--    1 root     root        15436 Dec 20 19:30 
module-info-2.4.20-2.2smp 
-rw-r--r--    1 root     root          640 Dec 12 20:39 os2_d.b 
lrwxrwxrwx    1 root     root           27 Dec 25 12:09 System.map -> 
System.map-2.4.18-19.8.0smp 
-rw-r--r--    1 root     root       502652 Nov 14 06:12 
System.map-2.4.18-18.8.0 
-rw-r--r--    1 root     root       519155 Nov 14 07:01 
System.map-2.4.18-18.8.0debug 
-rw-r--r--    1 root     root       524832 Nov 14 05:47 
System.map-2.4.18-18.8.0smp 
-rw-r--r--    1 root     root       502707 Dec 12 11:56 
System.map-2.4.18-19.8.0 
-rw-r--r--    1 root     root       519210 Dec 12 12:36 
System.map-2.4.18-19.8.0debug 
-rw-r--r--    1 root     root       524887 Dec 12 11:28 
System.map-2.4.18-19.8.0smp 
-rw-r--r--    1 root     root       547598 Dec 20 19:58 
System.map-2.4.20-2.2 
-rw-r--r--    1 root     root       570604 Dec 20 19:30 
System.map-2.4.20-2.2smp 
-rwxr-xr-x    1 root     root      3164943 Nov 14 06:12 
vmlinux-2.4.18-18.8.0 
-rwxr-xr-x    1 root     root      3277122 Nov 14 07:01 
vmlinux-2.4.18-18.8.0debug 
-rwxr-xr-x    1 root     root      3545762 Nov 14 05:47 
vmlinux-2.4.18-18.8.0smp 
-rwxr-xr-x    1 root     root      3165056 Dec 12 11:56 
vmlinux-2.4.18-19.8.0 
-rwxr-xr-x    1 root     root      3277235 Dec 12 12:36 
vmlinux-2.4.18-19.8.0debug 
-rwxr-xr-x    1 root     root      3545875 Dec 12 11:28 
vmlinux-2.4.18-19.8.0smp 
-rwxr-xr-x    1 root     root      2710472 Dec 20 19:58 vmlinux-2.4.20-2.2 
-rwxr-xr-x    1 root     root      3077880 Dec 20 19:31 
vmlinux-2.4.20-2.2smp 
lrwxrwxrwx    1 root     root           18 Dec 25 05:29 vmlinuz -> 
vmlinuz-2.4.20-2.2 
-rw-r--r--    1 root     root      1109491 Nov 14 06:12 
vmlinuz-2.4.18-18.8.0 
-rw-r--r--    1 root     root      1146337 Nov 14 07:01 
vmlinuz-2.4.18-18.8.0debug 
-rw-r--r--    1 root     root      1185822 Nov 14 05:47 
vmlinuz-2.4.18-18.8.0smp 
-rw-r--r--    1 root     root      1109334 Dec 12 11:56 
vmlinuz-2.4.18-19.8.0 
-rw-r--r--    1 root     root      1146521 Dec 12 12:36 
vmlinuz-2.4.18-19.8.0debug 
-rw-r--r--    1 root     root      1185901 Dec 12 11:28 
vmlinuz-2.4.18-19.8.0smp 
-rw-r--r--    1 root     root      1196046 Dec 20 19:58 vmlinuz-2.4.20-2.2 
-rw-r--r--    1 root     root      1275823 Dec 20 19:30 
vmlinuz-2.4.20-2.2smp 
[root@haskaa boot]# more ./grub/grub.conf 
# grub.conf generated by anaconda 
# 
# Note that you do not have to rerun grub after making changes to this file 
# NOTICE:  You have a /boot partition.  This means that 
#          all kernel and initrd paths are relative to /boot/, eg. 
#          root (hd0,0) 
#          kernel /vmlinuz-version ro root=/dev/hda5 
#          initrd /initrd-version.img 
#boot=/dev/hda 
default=2 
timeout=10 
splashimage=(hd0,0)/grub/splash.xpm.gz 
title Red Hat Linux (2.4.20-2.2smp) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.20-2.2smp ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.20-2.2smp.img 
title Red Hat Linux (2.4.20-2.2) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.20-2.2 ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.20-2.2.img 
title Red Hat Linux (2.4.18-19.8.0smp) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.18-19.8.0smp ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.18-19.8.0smp.img 
title Red Hat Linux (2.4.18-19.8.0debug) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.18-19.8.0debug ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.18-19.8.0debug.img 
title Red Hat Linux (2.4.18-19.8.0) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.18-19.8.0 ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.18-19.8.0.img 
title Red Hat Linux (2.4.18-18.8.0smp) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.18-18.8.0smp ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.18-18.8.0smp.img 
title Red Hat Linux (2.4.18-18.8.0debug) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.18-18.8.0debug ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.18-18.8.0debug.img 
title Red Hat Linux (2.4.18-18.8.0) 
        root (hd0,0) 
        kernel /vmlinuz-2.4.18-18.8.0 ro root=/dev/hda5 vga=0x317 
        initrd /initrd-2.4.18-18.8.0.img 
 
(Machine details are available (if RedHat developers do have access to these) 
at rhn.redhat.com under IvoS account.)
Comment 1 Arjan van de Ven 2002-12-25 06:47:54 EST
Developers don't have access to that information (for privacy reasons etc).
The bit that looks most important is the type of IDE controller your system has.
If you don't know, please just attach the output of lspci, that has the
information in it.
Comment 2 Arjan van de Ven 2002-12-25 06:52:38 EST
also if you <A>ppend the following command option in grub "acpi=off", does that
fix it ?
Comment 3 Ivo Sarak 2002-12-25 06:54:38 EST
This machine has a ASUSTeK A7M266-D board with 2*AMD Athlon XP 1700+ attached to
it...

[root@haskaa root]# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System
Controller (rev 11)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP Bridge
00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ISA (rev 04)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-768 [Opus] IDE (rev 04)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ACPI (rev 03)
00:10.0 PCI bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] PCI (rev 04)
01:05.0 VGA compatible controller: ATI Technologies Inc Rage 128 Pro Ultra TF
02:04.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
02:06.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 64)
[root@haskaa root]#
Comment 4 Arjan van de Ven 2002-12-25 07:00:51 EST
ok can you try to see if there are IDE related failure messages during the boot
phase (yes I know it's a pain since they scroll by)
Comment 5 Ivo Sarak 2002-12-25 07:12:07 EST
No differences with:

title Red Hat Linux (2.4.20-2.2smp)
        root (hd0,0)
        kernel /vmlinuz-2.4.20-2.2smp ro root=/dev/hda5 vga=0x317 acpi=off
        initrd /initrd-2.4.20-2.2smp.img
Comment 6 Ivo Sarak 2002-12-25 07:18:15 EST
Just in case it is somewhat helpful, this is the dmesg output of "working"
kernel 2.4.18-19.8.0smp:

[root@haskaa root]$ dmesg
Linux version 2.4.18-19.8.0smp (bhcompile@tweety.devel.redhat.com) (gcc version
3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 SMP Thu Dec 12 04:08:48 EST 2002
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001ffec000 (usable)
 BIOS-e820: 000000001ffec000 - 000000001ffef000 (ACPI data)
 BIOS-e820: 000000001ffef000 - 000000001ffff000 (reserved)
 BIOS-e820: 000000001ffff000 - 0000000020000000 (ACPI NVS)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
511MB LOWMEM available.
found SMP MP-table at 000f6d10
hm, page 000f6000 reserved twice.
hm, page 000f7000 reserved twice.
hm, page 000f6000 reserved twice.
hm, page 000f7000 reserved twice.
On node 0 totalpages: 131052
zone(0): 4096 pages.
zone(1): 126956 pages.
zone(2): 0 pages.
Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
OEM ID: ASUS     Product ID: PROD00000000 APIC at: 0xFEE00000
Processor #0 Pentium(tm) Pro APIC version 16
Processor #1 Pentium(tm) Pro APIC version 16
I/O APIC #2 Version 17 at 0xFEC00000.
Processors: 2
Kernel command line: ro root=/dev/hda5 vga=0x317
Initializing CPU#0
Detected 1466.696 MHz processor.
Speakup v-1.00 CVS: Tue Jun 11 14:22:53 EDT 2002 : initialized
Console: colour dummy device 80x25
Calibrating delay loop... 2912.47 BogoMIPS
Memory: 510904k/524208k available (1427k kernel code, 10740k reserved, 1057k
data, 196k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 8192 (order: 4, 65536 bytes)
ramfs: mounted with options: <defaults>
ramfs: max_pages=64135 max_file_pages=0 max_inodes=0 max_dentries=64135
Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: Before vendor init, caps: 0383fbff c1cbfbff 00000000, vendor = 2
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After vendor init, caps: 0383fbff c1cbfbff 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0383fbff c1cbfbff 00000000 00000000
CPU:             Common caps: 0383fbff c1cbfbff 00000000 00000000
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
CPU: Before vendor init, caps: 0383fbff c1cbfbff 00000000, vendor = 2
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After vendor init, caps: 0383fbff c1cbfbff 00000000 00000000
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0383fbff c1cbfbff 00000000 00000000
CPU:             Common caps: 0383fbff c1cbfbff 00000000 00000000
CPU0: AMD Athlon(TM) MP 1700+ stepping 02
per-CPU timeslice cutoff: 731.61 usecs.
task migration cache decay timeout: 1 msecs.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Booting processor 1/1 eip 2000
Initializing CPU#1
masked ExtINT on CPU#1
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Calibrating delay loop... 2929.67 BogoMIPS
CPU: Before vendor init, caps: 0383fbff c1cbfbff 00000000, vendor = 2
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After vendor init, caps: 0383fbff c1cbfbff 00000000 00000000
Intel machine check reporting enabled on CPU#1.
CPU:     After generic, caps: 0383fbff c1cbfbff 00000000 00000000
CPU:             Common caps: 0383fbff c1cbfbff 00000000 00000000
CPU1: AMD Athlon(TM) MP 1700+ stepping 02
Total of 2 processors activated (5841.14 BogoMIPS).
ENABLING IO-APIC IRQs
Setting 2 in the phys_id_present_map
...changing IO-APIC physical APIC ID to 2 ... ok.
init IO_APIC IRQs
 IO-APIC (apicid-pin) 2-0, 2-3, 2-10, 2-11, 2-18, 2-20, 2-21, 2-22, 2-23 not
connected.
..TIMER: vector=0x31 pin1=2 pin2=0
number of MP IRQ sources: 18.
number of IO-APIC #2 registers: 24.
testing the IO APIC.......................

IO APIC #2......
.... register #00: 02000000
.......    : physical APIC id: 02
.... register #01: 00170011
.......     : max redirection entries: 0017
.......     : PRQ implemented: 0
.......     : IO APIC version: 0011
.... register #02: 00000000
.......     : arbitration: 00
.... IRQ redirection table:
 NR Log Phy Mask Trig IRR Pol Stat Dest Deli Vect:
 00 000 00  1    0    0   0   0    0    0    00
 01 003 03  0    0    0   0   0    1    1    39
 02 001 01  0    0    0   0   0    1    1    31
 03 000 00  1    0    0   0   0    0    0    00
 04 003 03  0    0    0   0   0    1    1    41
 05 003 03  0    0    0   0   0    1    1    49
 06 003 03  0    0    0   0   0    1    1    51
 07 003 03  0    0    0   0   0    1    1    59
 08 003 03  0    0    0   0   0    1    1    61
 09 003 03  0    0    0   0   0    1    1    69
 0a 000 00  1    0    0   0   0    0    0    00
 0b 000 00  1    0    0   0   0    0    0    00
 0c 003 03  0    0    0   0   0    1    1    71
 0d 003 03  0    0    0   0   0    1    1    79
 0e 003 03  0    0    0   0   0    1    1    81
 0f 003 03  0    0    0   0   0    1    1    89
 10 003 03  1    1    0   1   0    1    1    91
 11 003 03  1    1    0   1   0    1    1    99
 12 000 00  1    0    0   0   0    0    0    00
 13 003 03  1    1    0   1   0    1    1    A1
 14 000 00  1    0    0   0   0    0    0    00
 15 000 00  1    0    0   0   0    0    0    00
 16 000 00  1    0    0   0   0    0    0    00
 17 000 00  1    0    0   0   0    0    0    00
IRQ to pin mappings:
IRQ0 -> 0:2
IRQ1 -> 0:1
IRQ4 -> 0:4
IRQ5 -> 0:5
IRQ6 -> 0:6
IRQ7 -> 0:7
IRQ8 -> 0:8
IRQ9 -> 0:9
IRQ12 -> 0:12
IRQ13 -> 0:13
IRQ14 -> 0:14
IRQ15 -> 0:15
IRQ16 -> 0:16
IRQ17 -> 0:17
IRQ19 -> 0:19
.................................... done.
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 1466.1215 MHz.
..... host bus clock speed is 266.1286 MHz.
cpu: 0, clocks: 520784, slice: 173594
CPU0<T0:520784,T1:347184,D:6,S:173594,C:520784>
cpu: 1, clocks: 520784, slice: 173594
CPU1<T0:520784,T1:173584,D:12,S:173594,C:520784>
checking TSC synchronization across CPUs: passed.
migration_task 0 on cpu=0
migration_task 1 on cpu=1
mtrr: your CPUs had inconsistent fixed MTRR settings
mtrr: probably your BIOS does not setup all CPUs
PCI: PCI BIOS revision 2.10 entry at 0xf0de0, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router AMD768 [1022/7443] at 00:07.3
PCI->APIC IRQ transform: (B1,I5,P0) -> 16
PCI->APIC IRQ transform: (B2,I4,P0) -> 17
PCI->APIC IRQ transform: (B2,I6,P0) -> 17
BIOS failed to enable PCI standards compliance, fixing this error.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
speakup:  initialized device: /dev/synth, node (MAJOR 10, MINOR 25)
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
apm: disabled - APM is not SMP safe.
Starting kswapd
VFS: Diskquotas version dquot_6.5.0 initialized
vesafb: framebuffer at 0xf0000000, mapped to 0xe080d000, size 16384k
vesafb: mode is 1024x768x16, linelength=2048, pages=9
vesafb: protected mode interface info at c000:442f
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
Console: switching to colour frame buffer device 128x48
fb0: VESA VGA frame buffer device
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
Real Time Clock Driver v1.10e
block: 992 slots per queue, batch=248
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD7441: IDE controller on PCI bus 00 dev 39
AMD7441: chipset revision 4
AMD7441: not 100% native mode: will probe irqs later
AMD7441: disabling single-word DMA support (revision < C4)
    ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:DMA
hda: WDC WD1200BB-00CAA0, ATA DISK drive
hdb: WDC WD1200BB-00CAA0, ATA DISK drive
hdc: WDC WD1200BB-00CAA0, ATA DISK drive
hdd: IC35L120AVVA07-0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
blk: queue c042ab64, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c042ab64, I/O limit 4095Mb (mask 0xffffffff)
hda: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
blk: queue c042acac, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c042acac, I/O limit 4095Mb (mask 0xffffffff)
hdb: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
blk: queue c042aec0, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c042aec0, I/O limit 4095Mb (mask 0xffffffff)
hdc: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=232581/16/63, UDMA(100)
blk: queue c042b008, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c042b008, I/O limit 4095Mb (mask 0xffffffff)
hdd: 241254720 sectors (123522 MB) w/1863KiB Cache, CHS=239340/16/63, UDMA(100)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 hda3 < hda5 hda6 >
 hdb: hdb1
 hdc: [PTBL] [14593/255/63] hdc1
 hdd: hdd1 hdd2
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 32768)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 131k freed
VFS: Mounted root (ext2 filesystem).
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 196k freed
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,5), internal journal
LVM version 1.0.3(19/02/2002) module loaded
loop: loaded (max 8 devices)
Adding Swap: 2097136k swap-space (priority -1)
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,1), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide1(22,1), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,65), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,6), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide1(22,65), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide1(22,66), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
ohci1394: pci_module_init failed
ip_tables: (C) 2000-2002 Netfilter core team
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
02:06.0: 3Com PCI 3c905B Cyclone 100baseTx at 0xa400. Vers LK1.1.18-ac
divert: allocating divert_blk for eth0
cipcb: CIPE driver vers 1.4.5 (c) Olaf Titz 1996-2000, 4 channels, debug=0
divert: not allocating divert_blk for non-ethernet device cipcb0
cmpci: version $Revision: 5.64 $ time 04:26:01 Dec 12 2002
cmpci: found CM8738 adapter at io 0xa800 irq 17
cmpci: chip version = 055
cmpci: Enable SPDIF loop
[root@haskaa root]$
Comment 7 Ivo Sarak 2002-12-25 08:28:40 EST
I reconstructed=handtyped all I could read from screen:
FDC is a post-1991 82077
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD7441: IDE controller at PCI 00:07.1
AMD7441: chipset revision 4
AMD7441: not 100%native mode: will probe irqs later
 ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:DMA
 ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:DMA
hda: 23441648 sectors (120034 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
hdb: 23441648 sectors (120034 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
blk: queue c04755c0, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c0475710, I/O limit 4095Mb (mask 0xffffffff)
hdc: 23441648 sectors (120034 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
hdd: 241254720 (123522 MB)  w/1863KiB Cache, CHS=239340/16/63, UDMA(100)
blk: queue c0475a34, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c0475b84, i/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: host protected area => 1
hda: 234441648 sectors (129934 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
hdb: host protected area => 1
hdb: 234441648 sectors (129934 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
hdc: host protected area => 1
hdc: 234441648 sectors (129934 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)
hdd: host protected area => 1
hdd: 241254720 sectors (123522 MB) w/1863KiB Cache, CHS=239340/16/63, UDMA(100)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1  hda2 hda3 < hda5 hda6 >
 hdb: hdb1
 hdc:<6> [PTBL] [14593/255/63] hdc1
 hdd: hdd1 hdd2
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
mb: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbutes
TCP: Hash tables configured (extablished 32768 bind 32768)
Linux IP multicast router 0.06 plus PIM-SM
NET: Unix domain socets 1.9/SMP for Linux NET4.0
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 65k freed
VFS: Mounted root (ext2 filesystem).
Red Hat nash version 3.4.28 starting
Mounting /proc filesystem
Creating block devices
Creating root device
Mounting root filesystem
mount: error 19 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
Freeing unused kernel memory: 152k freed
Kernel panic: No init found. Try passing init= option to kernel.
Comment 8 Ivo Sarak 2002-12-25 08:30:30 EST
I did not notice any IDE problems reported at boot time.
Comment 9 Ivo Sarak 2003-01-02 16:00:45 EST
Created attachment 89072 [details]
ASUS A7M266D ACPIdmp

acpidmp output on this machine.
Comment 10 Ivo Sarak 2003-01-02 16:02:51 EST
Created attachment 89073 [details]
ASUS A7M266D DMIdecode

dmidecode output on this machine.
Comment 11 Ivo Sarak 2003-01-26 06:14:28 EST
No problem with kernel-2.4.20-2.21smp.

Note You need to log in before you can comment on or make changes to this bug.