Bug 803745 - Incorrect password for rhev configuration results in an error message that the export does not exist in the storage domain
Incorrect password for rhev configuration results in an error message that th...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: beta6
: ---
Assigned To: Richard Su
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 10:42 EDT by chris alfonso
Modified: 2012-05-15 16:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 16:49:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris alfonso 2012-03-15 10:42:17 EDT
Description of problem:
aeolus-configure does a validation of the rhev configuration, it checks the existence of an export in a storage domain.  The way it accomplishes the validation check is it uses a curl command, which requires http authentication. As it stands now, if the username or password is incorrect, the curl command correctly results in an http auth failure, but the validation logic continues on without reporting the auth failure to the user.  The next part of the validation logic will parse the response body for the existence of the export in the storage domain.  Well, in this case, there isn't going to be a body to parse and the validation logic subsequently reports to the user that it can't find the export in the storage domain...

We should change this to raise a Puppet::ParseError or something similar to tell the user the authentication failed, so they can easily double check their password setup.

Version-Release number of selected component (if applicable):


How reproducible:
Run aeolus-configure to set up rhev, and have a bad password in the rhev node configuration.

Additional Info:
This is the error that was captured.

>RHEV validation error: could not find path /tempexport in data center f248dff3-df2a-4668-ad3e-638552e2cfe9 in a storage domain where type = "export" at                                      
+/usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm.pp:51 on node rhce-13.ace.saic.com
Comment 2 Richard Su 2012-03-20 19:04:16 EDT
Available on aeolus-configure master
commit 9de4f426cf291a09ff5f1e09abb4c219455b821d
Comment 4 dgao 2012-03-22 17:53:24 EDT
[root@dell-pem600-01 ~]# aeolus-configure -p rhevm
Launching aeolus configuration recipe...
Unable to authenticate with RHEV. Please check deltacloud_username and deltacloud_password in /etc/aeolus-configure/nodes/rhevm_configure. at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm.pp:51 on node dell-pem600-01.rhts.eng.bos.redhat.com
Comment 6 errata-xmlrpc 2012-05-15 16:49:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0586.html

Note You need to log in before you can comment on or make changes to this bug.