Bug 803746 - [RFE] Subscription Manager should support enabling/disabling repositories from the GUI
[RFE] Subscription Manager should support enabling/disabling repositories fro...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
high Severity unspecified
: rc
: 7.0
Assigned To: Michael Stead
IDM QE LIST
: FutureFeature
: 854339 (view as bug list)
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-03-15 10:44 EDT by Bryan Kearney
Modified: 2014-06-17 20:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:32:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the new subscription-manager-gui repo override dialog (41.88 KB, image/png)
2013-11-22 13:47 EST, John Sefler
no flags Details

  None (edit)
Description Bryan Kearney 2012-03-15 10:44:28 EDT
Subscirption manager should suppor the enabling/disabling of repos which it manages. Although this can be done in packagekit, the user should not have to leave the tool to do this.
Comment 10 Bryan Kearney 2012-10-17 16:51:45 EDT
*** Bug 854339 has been marked as a duplicate of this bug. ***
Comment 12 William Poteat 2013-06-05 07:38:43 EDT
Confirmed working in master commit b44c4b125746175cb88ac7a698dfc63170c7a93f
Comment 13 John Sefler 2013-10-15 12:35:18 EDT
Removing NEEDINFO flag since this RFE is now under development targeting a delivery with RHEL7.0
Comment 14 Michael Stead 2013-11-07 13:11:09 EST
Enable/Disable repositories in the GUI has been implemented as part of the 'repository overrides' feature, which has been merged into the master branch of subscription-manager.

Pull Request: https://github.com/candlepin/subscription-manager/pull/806

Will be available in:
subscription-manager-1.10.7-1
Comment 16 John Sefler 2013-11-22 13:47:25 EST
Created attachment 827952 [details]
screenshot of the new subscription-manager-gui repo override dialog

Verifying Version...
[root@jsefler-7 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription-manager: 1.10.7-1.el7
python-rhsm: 1.10.6-1.el7

The ability to override repo parameters (enabled and gpgcheck ONLY) is now available through the GUI:
See attached screenshot.



The ability to override repo parameters (all except baseurl) is now available through the CLI.

Here is the usage syntax via the CLI:
[root@jsefler-7 ~]# subscription-manager repo-override --help
Usage: subscription-manager repo-override [OPTIONS]

Manage custom content repository settings

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --repo=REPOID         repository to modify (can be specified more than once)
  --remove=NAME         name of the override to remove (can be specified more
                        than once)
  --add=NAME:VALUE      name and value of the option to override separated by
                        a colon (can be specified more than once)
  --remove-all          remove all overrides; can be specific to a repository
                        by providing --repo
  --list                list all overrides; can be specific to a repository by
                        providing --repo
Comment 17 John Sefler 2013-11-22 13:50:02 EST
Moving this RFE bug to VERIFIED
Subsequent issues with this new feature are being opened under separate bugzillas.
Comment 18 Ludek Smid 2014-06-13 05:32:56 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.