Bug 803757 - Systems: Users should not be able to enter anything other than positive integers for sockets
Systems: Users should not be able to enter anything other than positive integ...
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: William Poteat
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 11:23 EDT by Corey Welton
Modified: 2015-05-14 12:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-07 10:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2012-03-15 11:23:05 EDT
Description of problem:
When handrolling a system, users can enter non-integer values in the "Number of Sockets or LPARs" field. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Systems > +New System
2. Create a new system, providing a name, an arch; enter the value "-1" in the "Number of Sockets or LPARs" field.
3. Systems > $system > Details > Facts > cpu ; view results.
4. Repeat steps 1-3 with any of the following strings
"3-2", "abc", "四"

Actual results:
Values other than non-positive integers are allowed

Expected results:
Only positive integers are allowed

Additional info:
< bkearney> cswiii: the sockets fact is used 
< cswiii> bkearney: in what way?  and if it's used, I guess I shouldn't be able to enter random text in that field.
< bkearney> cswiii: no.. numbers are preferred :)
Comment 2 Adam Price 2012-07-20 17:35:21 EDT
turns out this is an issue with Candlepin accepting these values.
Comment 3 William Poteat 2013-01-08 14:11:41 EST
commit ebff18938b58a4ab87bc4b322f204b2ef45fa81b
Comment 4 Bryan Kearney 2014-11-07 10:55:41 EST
Candlepin 0.7.24 and beyond contain this fix. I am closing this out. If you are still seeing issues, pelase feel free to re-open it.

Note You need to log in before you can comment on or make changes to this bug.