Bug 803783 - [as7] shutdown, restart, and reload operations do not work on AS7 Server types
[as7] shutdown, restart, and reload operations do not work on AS7 Server types
Status: CLOSED DUPLICATE of bug 804102
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.3
Unspecified Unspecified
high Severity high (vote)
: ---
: RHQ 4.4.0
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-03-15 12:10 EDT by Ian Springer
Modified: 2013-08-05 20:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
AS 7.1.1.Final
Last Closed: 2012-03-26 11:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2012-03-15 12:10:36 EDT
---shutdown---
For a Standalone Server, shutdown returns the following error:

<Operation <Operation{operation='shutdown', address=Address{path: }, additionalProperties={}}> returned <"JBAS010850: No handler for operation shutdown at address []","rolled-back":true}>, rolled-back=false>

For a Domain Server, shutdown does not fail with this error, but it does not appear to actually shutdown the server.

---restart---
For a Standalone Server, restart fails with the same error, because under the covers it calls the shutdown operation.

---reload---
For a Standalone Server, reload returns the following error:

<Operation <Operation{operation='reload', address=Address{path: }, additionalProperties={}}> returned <"JBAS010850: No handler for operation reload at address []","rolled-back":true}>, rolled-back=false>

---start---
Due to the design of my integration tests, I am unable to test the start operation until the shutdown operation is fixed, so I am not sure whether the start operation is working on either Server type.
Comment 2 Heiko W. Rupp 2012-03-16 06:44:11 EDT
comment #1 was bogus and for a different BZ
Comment 3 Heiko W. Rupp 2012-03-16 08:39:13 EDT

-- domain --

- shutdown works, but sometimes the server returns 'strange results' -- See also https://issues.jboss.org/browse/AS7-4192


-- standalone
- reload always works for me
- shutdown and start (and re-start) also work


For restart commit 7228af6170578 adds a larger (dynamic) wait time between shutdown and start to make sure the server is no longer responding to management requests before starting again.
Comment 4 Heiko W. Rupp 2012-03-16 08:39:37 EDT
Ian can you check if that helps you?
Comment 5 Mike Foley 2012-03-19 11:34:47 EDT
per BZ triage (crouch, loleary, mfoley)
Comment 6 Heiko W. Rupp 2012-03-19 12:28:18 EDT
finally pushed as 7228af6170578 to master
Comment 7 Heiko W. Rupp 2012-03-26 11:15:17 EDT
Closing - further work is done in Bug 804102

*** This bug has been marked as a duplicate of bug 804102 ***

Note You need to log in before you can comment on or make changes to this bug.