Bug 803794 - Error updating firefox in rawhide
Error updating firefox in rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 12:43 EDT by Bruno Wolff III
Modified: 2014-01-21 18:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 10:31:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-03-15 12:43:10 EDT
Description of problem:
I got the following message after doing yum install -y firefox:

[root@bruno bruno]# yum install -y firefox
Loaded plugins: aliases, changelog, downloadonly, keys, list-data, merge-conf,
              : post-transaction-actions, priorities, protectbase, remove-with-
              : leaves, rpm-warm-cache, show-leaves, tmprepo, tsflags, verify,
              : versionlock
Setting up Install Process
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package firefox.i686 0:11.0-1.fc18 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package           Arch           Version               Repository         Size
================================================================================
Installing:
 firefox           i686           11.0-1.fc18           rawhide            20 M

Transaction Summary
================================================================================
Install  1 Package

Total download size: 20 M
Installed size: 24 M
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
gecko-libs(x86-32) = 11.0-3-1 is needed by firefox-11.0-1.fc18.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
 You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-03-15.11-38.sWJ3wh.yumtx


Version-Release number of selected component (if applicable):
yum-3.4.3-22.fc18.noarch

How reproducible:
Seems to happen 100% of the time updating to or installing firefox.i686 0:11.0-1.fc18 on my machine, though it's likely an i686 specific issue given the error message.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mikhael Goikhman 2012-03-17 19:43:53 EDT
The problem seems to be solved in 11.0-2.fc18.
Comment 2 Bruno Wolff III 2012-03-18 10:53:37 EDT
Maybe. The latest firefox update no longer triggers the problem, but that doesn't mean the yum issue is fixed. Yum didn't detect the issue while depsolving, so that skipbroken could skip the firefox update and update other stuff. The error message specifically requested a bug filed against yum rather than the package that triggered the problem.
Comment 3 James Antill 2012-03-22 10:31:50 EDT
Yeh, but as I've said in other reports of this bug ... this is really a specfile/rpmbuild problem as the version was broken.

Note You need to log in before you can comment on or make changes to this bug.