Bug 803831 - Persistence fails when running multiple threads with exclusive EntityManager for each thread
Persistence fails when running multiple threads with exclusive EntityManager ...
Status: CLOSED DUPLICATE of bug 805899
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5 (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: BRMS 5.3.0.GA
Assigned To: Marco Rietveld
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 13:55 EDT by Jiri Svitak
Modified: 2016-09-20 01:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 07:04:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace (824.75 KB, text/plain)
2012-03-15 13:55 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2012-03-15 13:55:36 EDT
Created attachment 570370 [details]
Stack trace

I have created a test which runs multiple threads in parallel. Each thread has its own ksession. Every thread uses its own EntityManager. Threads share the same database for persisting process instances, work items and session information.

If I use single entity manager which is shared by the threads, then everything is persisted fine.

I have attached error stack trace in file, because the stack trace is very long. This stack trace happened with MySQL database.

I have also tried local HSQL database, but the exception is a bit different and shorter.

I am working on a test case, it is available here
https://github.com/jsvitak/jbpm/blob/parallelProcessPersistence/jbpm-test/src/test/java/org/jbpm/persistence/ProcessMultiThreadPersistenceTest.java

But it is not finished and working yet. I am working on a pull request.
Comment 1 Marco Rietveld 2012-04-11 05:29:21 EDT
Jiri, 

It seems like this might be a duplicate of 805899. 

If this is not a duplicate, could you add some additional detail as to why the issue/cause here is different than in 805899? 

Thanks,
Marco
Comment 2 Marco Rietveld 2012-04-11 07:04:33 EDT
It turns out that 805899 covers this same issue, please see that issue for more information.

*** This bug has been marked as a duplicate of bug 805899 ***

Note You need to log in before you can comment on or make changes to this bug.