Bug 803845 - vte-0.25.1-7.el6.x86_64 does not set TERM for terminal emulators other than gnome-terminal
vte-0.25.1-7.el6.x86_64 does not set TERM for terminal emulators other than g...
Status: CLOSED DUPLICATE of bug 754557
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vte (Show other bugs)
6.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Bžatek
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 14:32 EDT by devurandom
Modified: 2015-03-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 08:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description devurandom 2012-03-15 14:32:42 EDT
Description of problem:
It appears to me that bug #639280 against Fedora 14 appears also 
in Scientific Linux 6.2: E.g. in Guake $TERM is "dumb" instead of "xterm".

Version-Release number of selected component (if applicable):
vte-0.25.1-7.el6.x86_64

How reproducible:
Type "echo $TERM" in Guake installed in SL 6.2.

Actual results:
Output is "dumb"

Expected results:
Output should be "xterm"
Comment 2 devurandom 2012-03-23 09:55:07 EDT
I initially mentioned this on the scientific-linux-users mailinglist and two others tried and could not reproduce.

Vladimir Mosgalin wrote:
---
I, too, have no problems - I'm using vte-based roxterm. Always had
"xterm" TERM in SL 6.1 and 6.2.
I checked other vte-based terminal emulator that I used in the past,
sakura; it works just fine out of the box, too.

There are tons of vte-based terminals out there, and from that bug it's
hard to say how many people are affected: the problem, if present, seems
to be confirmed for just a few of them. So maybe most of people never
notice if this bug is present at all.
---
Comment 3 Ludwin Janvier 2012-06-01 09:02:40 EDT
Isn't this a duplicate of #754557 ?
Comment 4 devurandom 2012-06-01 16:37:05 EDT
(In reply to comment #3)
> Isn't this a duplicate of #754557 ?
Yes.

Bugzilla seems broken to me - I cannot mark this bug as a dupe and neither can I close it... Can someone else please do that?
Comment 5 Ludwin Janvier 2012-06-01 16:45:25 EDT
below "additional comments", you should haev a 'Mark as Duplicate" link.
Comment 6 devurandom 2012-06-01 16:57:22 EDT
(In reply to comment #5)
> below "additional comments", you should haev a 'Mark as Duplicate" link.
Yes. Clicking it removes the link and adds a "#" in the URL field, but nothing else happens. Also notable is that the "Status: ..." line below the comment field and left to "Save Changes" shows "NEW" just as a text (i.e. no drop down field) and selecting any resolution from the drop down field next to the status just does nothing. I assume something broke the JavaScript fancyness.
Comment 7 Tomáš Bžatek 2012-06-04 08:29:29 EDT

*** This bug has been marked as a duplicate of bug 754557 ***

Note You need to log in before you can comment on or make changes to this bug.