Bug 803850 - BUG: unable to handle kernel NULL pointer dereference at 000000000000013e ieee80211_key_disable_hw_accel()
BUG: unable to handle kernel NULL pointer dereference at 000000000000013e iee...
Status: CLOSED DUPLICATE of bug 803853
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:3f71a43728d338298da89608267...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 14:42 EDT by jan p. springer
Modified: 2012-03-20 07:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 07:53:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jan p. springer 2012-03-15 14:42:53 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.2.9-2.fc16.x86_64 root=UUID=e7495b4a-4b58-4d0d-88c0-89cfe6fc124d ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=C
kernel:         3.2.9-2.fc16.x86_64
reason:         BUG: unable to handle kernel NULL pointer dereference at 000000000000013e
time:           Thu Mar 15 18:05:25 2012

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 000000000000013e
:IP: [<ffffffffa0247f09>] ieee80211_key_disable_hw_accel+0x39/0x260 [mac80211]
:PGD 20f283067 PUD 20f5e2067 PMD 0 
:Oops: 0000 [#1] SMP 
:CPU 0 
:Modules linked in: binfmt_misc ppdev parport_pc lp parport tcp_lp hidp fuse lockd 8021q garp stp llc fcoe libfcoe libfc scsi_transport_fc scsi_tgt rfcomm bnep ip6t_REJECT nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant arc4 cdc_ncm usbnet mii cdc_wdm uvcvideo cdc_acm videodev media v4l2_compat_ioctl32 sparse_keymap joydev btusb bluetooth microcode iTCO_wdt iTCO_vendor_support i2c_i801 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm iwlwifi mac80211 e1000e cfg80211 snd_timer snd_page_alloc thinkpad_acpi rfkill snd tpm_tis soundcore tpm tpm_bios uinput sunrpc sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1059, comm: wpa_supplicant Tainted: G        W    3.2.9-2.fc16.x86_64 #1 LENOVO 12943QG/12943QG
:RIP: 0010:[<ffffffffa0247f09>]  [<ffffffffa0247f09>] ieee80211_key_disable_hw_accel+0x39/0x260 [mac80211]
:RSP: 0018:ffff8801fa58f8c8  EFLAGS: 00010286
:RAX: 00000000000000be RBX: ffff880021cf4400 RCX: dead000000200200
:RDX: ffff8801fa58ffd8 RSI: ffff88020e5b2e60 RDI: ffff880021cf4400
:RBP: ffff8801fa58f918 R08: ffff8801fa58f868 R09: 0000000000000000
:R10: 0000000000000000 R11: 0000000000000000 R12: ffff88020d960f88
:R13: ffff880021cf6e00 R14: 0000000000000000 R15: 0000000000000001
:FS:  00007f746c8517c0(0000) GS:ffff88021e200000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 000000000000013e CR3: 000000020caac000 CR4: 00000000000406f0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process wpa_supplicant (pid: 1059, threadinfo ffff8801fa58e000, task ffff88020e5b2e60)
:Stack:
: 0000000000000000 ffffffff8108d780 ffff880100000000 ffffffff00030003
: ffff8801fa58f8e8 ffff880021cf4400 ffff88020d960f88 ffff88020d961910
: 0000000000000000 0000000000000001 ffff8801fa58f938 ffffffffa0248159
:Call Trace:
: [<ffffffff8108d780>] ? wait_rcu_gp+0x50/0x50
: [<ffffffffa0248159>] __ieee80211_key_destroy+0x29/0x90 [mac80211]
: [<ffffffffa0248682>] __ieee80211_key_free+0x42/0x50 [mac80211]
: [<ffffffffa023c18a>] ieee80211_del_key+0x8a/0xe0 [mac80211]
: [<ffffffffa01b2c10>] nl80211_del_key+0x110/0x170 [cfg80211]
: [<ffffffff814ff295>] genl_rcv_msg+0x1d5/0x250
: [<ffffffff814ff0c0>] ? genl_rcv+0x40/0x40
: [<ffffffff814feb59>] netlink_rcv_skb+0xa9/0xd0
: [<ffffffff814ff0a5>] genl_rcv+0x25/0x40
: [<ffffffff814fe4b8>] netlink_unicast+0x2a8/0x2f0
: [<ffffffff814cbc27>] ? memcpy_fromiovec+0x67/0xb0
: [<ffffffff814fe7b6>] netlink_sendmsg+0x2b6/0x310
: [<ffffffff814be01e>] sock_sendmsg+0x10e/0x130
: [<ffffffff812752ba>] ? symhash+0x1a/0x60
: [<ffffffff81281f9f>] ? mls_level_isvalid+0xef/0x160
: [<ffffffff8127424a>] ? ebitmap_cmp+0x8a/0xb0
: [<ffffffff81275a25>] ? sidtab_context_to_sid+0x2b5/0x460
: [<ffffffff81165ccb>] ? kfree+0x3b/0x150
: [<ffffffff814c0a41>] ? move_addr_to_kernel+0x71/0x80
: [<ffffffff814cbf26>] ? verify_iovec+0x56/0xd0
: [<ffffffff814bf5b6>] __sys_sendmsg+0x396/0x3b0
: [<ffffffff814bd483>] ? sock_destroy_inode+0x33/0x40
: [<ffffffff81165adf>] ? kmem_cache_free+0x2f/0x130
: [<ffffffff8118fd6b>] ? __d_free+0x4b/0x70
: [<ffffffff8118ff3d>] ? d_free+0x5d/0x70
: [<ffffffff81191057>] ? d_kill+0xa7/0x100
: [<ffffffff81198a64>] ? mntput_no_expire+0x24/0x100
: [<ffffffff814c19d9>] sys_sendmsg+0x49/0x90
: [<ffffffff815ec682>] system_call_fastpath+0x16/0x1b
:Code: 65 e0 4c 89 6d e8 4c 89 75 f0 4c 89 7d f8 66 66 66 66 90 48 89 fb e8 e7 a5 39 e1 48 85 db 0f 84 e5 00 00 00 4c 8b 2b 49 8b 45 68 <48> 83 b8 80 00 00 00 00 0f 84 d0 00 00 00 f6 43 28 01 0f 84 c6 
:RIP  [<ffffffffa0247f09>] ieee80211_key_disable_hw_accel+0x39/0x260 [mac80211]
: RSP <ffff8801fa58f8c8>

smolt_data:
:
:
:General
:=================================
:UUID: ec12badf-c750-4868-9967-0a2c56d66828
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: C
:Platform: x86_64
:BogoMIPS: 5581.54
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2801
:System Memory: 7870
:System Swap: 8625
:Vendor: LENOVO
:System: 12943QG ThinkPad X1
:Form factor: Notebook
:Kernel: 3.2.9-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4147:404:6058:8680) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7247:6058:8680) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4480:59427:6058:8680) pci, sdhci-pci, BASE, N/A
:(32902:294:6058:8680) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8680) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8680) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8680) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:6058:8680) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7192:6058:8680) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8680) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7213:6058:8680) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7202:6058:8680) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:16952:32902:4369) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:7171:6058:8680) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7229:6058:8680) pci, serial, 16550_SERIAL, 6 Series/C200 Series Chipset Family KT Controller
:(32902:7206:6058:8680) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8680) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8680) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 36827210 15990008 15621467 9216000 8688809 8688809
:
Comment 1 Josh Boyer 2012-03-15 14:50:48 EDT
Seems like related fallout from 803853
Comment 2 Stanislaw Gruszka 2012-03-20 07:53:39 EDT

*** This bug has been marked as a duplicate of bug 803853 ***

Note You need to log in before you can comment on or make changes to this bug.