Bug 803871 - Jack should be compiled with a higher limit for "ports-per-application" and "clients"
Jack should be compiled with a higher limit for "ports-per-application" and "...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jack-audio-connection-kit (Show other bugs)
16
All Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraAudio
  Show dependency treegraph
 
Reported: 2012-03-15 15:26 EDT by Fernando Lopez-Lezcano
Modified: 2012-04-11 22:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: jack-audio-connection-kit-1.9.8-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 22:26:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fernando Lopez-Lezcano 2012-03-15 15:26:49 EDT
Description of problem:
In some situations Jack can run out of internal connection ports. Usually the server dies with an assertion error and takes down all Jack clients with it. This happens when running very complex Ardour mixing sessions (or any other application that uses lots of Jack ports), specially if Ambisonics is being used to spatialize the sound (the main Ambisonics mixing bus is 16 channels wide and a complex mix uses a lot of Jack ports). 

Version-Release number of selected component (if applicable):
All

How reproducible:
Not easy to reproduce, but I was getting random crashes with the aforementioned symptoms at least once a day. 

Steps to Reproduce:
1. Build a very complex Ardour session, one way is to have many tracks with Ambisonics spatialization plugins (3rd order which means 16 channels wide). 
2. Work on the mix, eventually the Jack server dies with an assertion error

Actual results:
Jack server dies, takes down all running Jack clients

Expected results:
No problems when building large Ardour sessions. 

Additional info:
I have solved the problem by building Jack with a different setting for ports-per-application and clients, in the configure step add:

--clients 256 --ports-per-application=2048

(the defaults are 64 and 768 respectively)

Since I built packages with those options I have not seen another crash of Jack. This should be propagate to build for all currently supported versions of Fedora.
Comment 1 Orcan Ogetbil 2012-03-16 08:38:10 EDT
Hi Fernando,
Does this have any drawbacks for other applications, how much additional memory does your suggestion demand ? Why are the default values low?
Comment 2 Fernando Lopez-Lezcano 2012-03-16 13:23:07 EDT
(In reply to comment #1)
> Hi Fernando,
> Does this have any drawbacks for other applications, how much additional memory
> does your suggestion demand ? Why are the default values low?

I don't think this would have drawbacks and I have not measured how much additional memory this uses. I don't think the default values are "low", just that now in some situations many many ports are used - I guess it was not very common at the time the defaults were chosen to have that many but it is more common now. 

I could raise these questions in the jack lists...
Comment 3 Fedora Update System 2012-03-25 15:19:52 EDT
jack-audio-connection-kit-1.9.8-6.fc17, libffado-2.1.0-0.8.20120325.svn2088.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-4542/jack-audio-connection-kit-1.9.8-6.fc17,libffado-2.1.0-0.8.20120325.svn2088.fc17
Comment 4 Orcan Ogetbil 2012-03-25 15:37:06 EDT
Note that the above update addresses F-17 only.

It also updates libffado to a recent revision and fixes a segfault in jack-connect.

We will yet to find solutions to bugs #795094 and #803865. Then we can file another update addressing those issues.
Comment 5 Fedora Update System 2012-03-25 17:28:24 EDT
Package jack-audio-connection-kit-1.9.8-6.fc17, libffado-2.1.0-0.8.20120325.svn2088.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jack-audio-connection-kit-1.9.8-6.fc17 libffado-2.1.0-0.8.20120325.svn2088.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4542/jack-audio-connection-kit-1.9.8-6.fc17,libffado-2.1.0-0.8.20120325.svn2088.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-11 22:26:58 EDT
jack-audio-connection-kit-1.9.8-6.fc17, libffado-2.1.0-0.8.20120325.svn2088.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.